BlackShadow
Results 1 to 8 of 8

Thread: HELP ASAP! LEadlight

  1. #1

    Default HELP ASAP! LEadlight

    I just got my leadlight glp 105 in the mail, it worked fine, when i went to pop the button for the pot to be visible, it came off with ease. When i pressed the button for the laser to turn on without the plastic piece in it, it went on but about 2 seconds later shut off, and will not turn on again. This is before any touching of the pot... If i press the button there is a small green glow inside of the laser casing but nothing actually comes out of the laser lens. I tried to turn the pot or whatever, please someone please get me on aim or respond here.

    If you can get me on aim its mihlrad828

    Thank you in advance... this is so my luck.

  2. #2
    Flashaholic FlashlightPhreak's Avatar
    Join Date
    May 2005
    Location
    Louisiana Gulfcoast area
    Posts
    227

    Shrug Re: HELP ASAP! LEadlight

    Sounds like the module has burned out. There's some sensitive stuff inside.

    Hope I'm wrong.

  3. #3

    Default Re: HELP ASAP! LEadlight

    but there is still a green glow INSIDE the casing. Nothing comes out of the lens, but if i press on the button a green glow appears.

  4. #4

    Default Re: HELP ASAP! LEadlight

    Could the switch under the plastic have moved around?

  5. #5

    Default Re: HELP ASAP! LEadlight

    Sounds like something is blocking the beam if there's a glow. You'll probably have to take it apart. How you do that is dependent on what model you have. I think on the 105 the end cap is just friction fitted, so with a bit of "coaxing" it should come off. After that you should be able to slide the module assembly out. At that point hopefully you will be able to just see what the problem is.

  6. #6
    Flashaholic jkaiser3000's Avatar
    Join Date
    Oct 2005
    Location
    Caracas, Venezuela
    Posts
    297

    Default Re: HELP ASAP! LEadlight

    I agree with ajohnson. Try the following:

    1.- Without turning the laser on, look inside the aperture and see if there's something blocking it, maybe behind the lens. Don't do that wiht the laser on, even if you don't see any light.


    2.- put the laser infront of a digital camera and see, through the camera, if there's any IR light being emitted from the laser. If there is, then probably the crystals moved somewhat inside.

    If this fails, you'll need to open your pointer and take a look inside. My guess is something moved inside, probably the diode or the lens, and it's preventing the light from exiting through the apperture.

    Another possiblity is that you have a 110, with the green led inside the case, and that's the green light you see when you press the button. That's a far fetched possibility, but possible nonetheless

  7. #7

    Default Re: HELP ASAP! LEadlight

    Either that or you shorted out the diode by pressing the button and touching the case.I really doubt it because you say it happened in about 2 secs. but I have seen lasers short out that fast.Well good luck.

  8. #8

    Default Re: HELP ASAP! LEadlight

    The green glow is probably from the LED light, because this may be a leadlight 110.

    One of the laser leads may have become desoldered from the board. Pop the laser module out and have a good look at the circuit board and all of the connections.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •