The Fenix-Store
Results 1 to 9 of 9

Thread: Parasitic Drain in Princeton Tec EOS?

Hybrid View

  1. #1
    Flashaholic*
    Join Date
    Apr 2006
    Location
    Land of the Bean and the Cod
    Posts
    1,796

    Default Parasitic Drain in Princeton Tec EOS?

    Has anyone had a set of fresh batteries discharge significantly while sitting in an EOS? I put some fresh Duracell batteries in a few months ago. The light was used for maybe 15 minutes, probably less. I tried using it last night and the batteries are apparently discharged enough that it won't run on "high." (High and medium were the same brightness. All other modes worked fine.) I put in another set of batteries and high runs as it should. I'm puzzled - wondering if there's a parasitic drain in the EOS?

    Found this thread, but it doesn't seem conclusive.
    MD3 | M6CB | Gladius/SSCP4 | A2-HA-WH | A2-HA-YG | A2-BK-WH | Z3/KT2 | M2 | C2 | 6Z | 6P | U2A | K2MS | E2e/KL4 BK | E2DL | E2D | E2L | L2 | Milky ML1/SSCP4 USWOH McR18j | L1-BK-RD | L1-HA-WH | L1-HA-WH Cree | L1-HA-RD | 3P | E1B | E1L | E1E-HA-BK | E1W | 618FA | G2

  2. #2
    *Flashaholic* greenLED's Avatar
    Join Date
    Mar 2004
    Location
    La Tiquicia
    Posts
    13,244

    Default Re: Parasitic Drain in Princeton Tec EOS?

    Yeah, sorry to say I couldn't figure out what was wrong with the light. PT did send me a new one, though (gotta love their CS).

  3. #3
    Flashaholic*
    Join Date
    Apr 2006
    Location
    Land of the Bean and the Cod
    Posts
    1,796

    Default Re: Parasitic Drain in Princeton Tec EOS?

    Quote Originally Posted by greenLED View Post
    Yeah, sorry to say I couldn't figure out what was wrong with the light. PT did send me a new one, though (gotta love their CS).
    Thanks, Green. They replaced it with a new EOS, yes? Does the new one have any issues???
    MD3 | M6CB | Gladius/SSCP4 | A2-HA-WH | A2-HA-YG | A2-BK-WH | Z3/KT2 | M2 | C2 | 6Z | 6P | U2A | K2MS | E2e/KL4 BK | E2DL | E2D | E2L | L2 | Milky ML1/SSCP4 USWOH McR18j | L1-BK-RD | L1-HA-WH | L1-HA-WH Cree | L1-HA-RD | 3P | E1B | E1L | E1E-HA-BK | E1W | 618FA | G2

  4. #4
    *Flashaholic* greenLED's Avatar
    Join Date
    Mar 2004
    Location
    La Tiquicia
    Posts
    13,244

    Default Re: Parasitic Drain in Princeton Tec EOS?

    Quote Originally Posted by JNewell View Post
    Thanks, Green. They replaced it with a new EOS, yes? Does the new one have any issues???
    Yup, brand-spanking-latest-version-new one. It's working great.

    As an aside, with the new emitters, I no longer see the need to mod the Eos into anything else (except if the emitter is still stock from the Lux days, of course).

  5. #5
    Flashaholic*
    Join Date
    Apr 2006
    Location
    Land of the Bean and the Cod
    Posts
    1,796

    Default Re: Parasitic Drain in Princeton Tec EOS?

    Quote Originally Posted by greenLED View Post
    Yup, brand-spanking-latest-version-new one. It's working great.

    As an aside, with the new emitters, I no longer see the need to mod the Eos into anything else (except if the emitter is still stock from the Lux days, of course).
    Thanks. I gave them a call and they immediately gave me an RMA. I'll be mailing it back tomorrow.
    MD3 | M6CB | Gladius/SSCP4 | A2-HA-WH | A2-HA-YG | A2-BK-WH | Z3/KT2 | M2 | C2 | 6Z | 6P | U2A | K2MS | E2e/KL4 BK | E2DL | E2D | E2L | L2 | Milky ML1/SSCP4 USWOH McR18j | L1-BK-RD | L1-HA-WH | L1-HA-WH Cree | L1-HA-RD | 3P | E1B | E1L | E1E-HA-BK | E1W | 618FA | G2

  6. #6

    Default Re: Parasitic Drain in Princeton Tec EOS?

    I had my 50 lumen EOS 2 (two mode) in my BOB for 6 months with LSD NiMH batteries and it worked great. Never seen any drain with my 50 lumen 4-mode too so gotta think it is an issue with a small number of headlamps not a standard problem. Oh snap now I gotta get a 70 lumen EOS. Maybe in orange to justify the purchase.

  7. #7
    Flashaholic*
    Join Date
    May 2006
    Location
    Johnson Point, WA
    Posts
    625

    Default Re: Parasitic Drain in Princeton Tec EOS?

    Quote Originally Posted by JNewell View Post
    Has anyone had a set of fresh batteries discharge significantly while sitting in an EOS?.... I'm puzzled - wondering if there's a parasitic drain in the EOS?...
    I was wondering the same thing about my Princeton Tec quad.

    The LSD cells in it were almost dead after maybe 20 minutes of use in a couple months. Usually they'd still be near fully charged.

    Recharged the cells and so far, so good.

    I chalked it up as maybe the HL got clicked on inadvertantly, but after reading this thread, I'm not so sure.

  8. #8
    Flashaholic*
    Join Date
    Oct 2002
    Location
    Baden.at
    Posts
    4,239

    Default

    from that similar thread, linked above:
    Quote Originally Posted by yellow
    open and check drain,
    but one rule of thumb: electrical switch --> drain
    mechanical switch --> no drain
    EOS - as far as I understand it - electrical pushbutton switch

    when not in use, get a small sheet of paper between one contact and cell, or remove batteries, or ...

    there has nothing changed here,
    also the info is not really difficult to understand

  9. #9
    Flashaholic*
    Join Date
    May 2006
    Location
    Johnson Point, WA
    Posts
    625

    Default Re: Parasitic Drain in Princeton Tec EOS?

    Yellow - thanks for the info.

    Electronic switch = parasitic drain.

    I've had that PT Quad HL (with electronic switch) for a couple years and its never drained before.

    Are all electronic switches subject to parasitic drain?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •