Results 1 to 6 of 6

Thread: Armytek Predator flickering with new 18650s

  1. #1
    Flashaholic
    Join Date
    Mar 2011
    Location
    So. California
    Posts
    122

    Default Armytek Predator flickering with new 18650s

    Hi everyone,


    Last night I received a pair of Orbtronic 3100mAh 18650's from Amazon. They charged with no issues up to 4.19v and I put one in my Armytek Predator v1 that had previously been running off of 2 CR123A's. However, when I turned it on low mode (Default 7 lumen pre-programmed setting) it stayed in a state of flickering.

    Some background info: my light (and I'm pretty sure everybody else's) would flicker for about half a second when entering the 7 lm mode. It pretty much looks like the same flickering that had been present with every other battery type, but instead of only lasting less than a second it keeps going. It isn't quite as constant as usual; sometimes it will stay on solidly for a few seconds before falling back into the flickering state.

    The light works fine with my Solarforce 2400mAh Protected 18650's (tried at 4.13v) and Tenergy CR123A's, but both Orbtronics have this same problem. Since noticing the issue I've left the Predator on in 7 lm mode sitting next to me for about 35 minutes now and the flickering seems to be getting a little better (less constant), but it's still there.

    Is this something that will disappear after a little use or is the Orbtronic/Armytek combo doomed to never work? Also, the Orbtronics work fine in my Fenix PD31 and Nailbender lights.

  2. #2
    Flashaholic
    Join Date
    Mar 2011
    Location
    So. California
    Posts
    122

    Default Re: Armytek Predator flickering with new 18650s

    Problem solved: I had forgotten that the Predator has a battery selection option in the setup menu. After navigating through the menu with the help of this excellent guide by petrev, I selected the 18650 setting and all of my problems went away.

  3. #3
    Flashaholic* tobrien's Avatar
    Join Date
    Dec 2005
    Location
    Georgia Highway 441
    Posts
    4,286

    Default Re: Armytek Predator flickering with new 18650s

    Quote Originally Posted by mwb01 View Post
    Problem solved: I had forgotten that the Predator has a battery selection option in the setup menu. After navigating through the menu with the help of this excellent guide by petrev, I selected the 18650 setting and all of my problems went away.
    what setting was it on? I have a predator but never thought much of the battery settings and didn't think those would make a different as long as the voltage was high enough
    aka Edgar Allan Bro, Brosama Bin Liftin, Walter Crunkite, Bro Namath, Teddy Brosevelt, and the Tomahawk Crunkmissile.
    my lights - review of PrecisionWorks - that's Gucci Mane in my avatar

  4. #4
    Flashaholic*
    Join Date
    Mar 2011
    Location
    USA
    Posts
    1,010

    Default Re: Armytek Predator flickering with new 18650s

    Your threads could be dirty if this happens again.

  5. #5
    Flashaholic
    Join Date
    Mar 2011
    Location
    So. California
    Posts
    122

    Default Re: Armytek Predator flickering with new 18650s

    Quote Originally Posted by tobrien View Post
    what setting was it on? I have a predator but never thought much of the battery settings and didn't think those would make a different as long as the voltage was high enough
    It was set to the CR123A mode when malfunctioning with the 18650's, all of which were above 4v when malfunctioning. In 18650 Li-ion mode there is no problem.

    I also never thought too much about the battery mode; I hadn't changed it since I got the light because I had always used it with CR123A primaries. I guess it does make a difference though.

  6. #6
    Flashaholic* tobrien's Avatar
    Join Date
    Dec 2005
    Location
    Georgia Highway 441
    Posts
    4,286

    Default Re: Armytek Predator flickering with new 18650s

    Quote Originally Posted by mwb01 View Post
    It was set to the CR123A mode when malfunctioning with the 18650's, all of which were above 4v when malfunctioning. In 18650 Li-ion mode there is no problem.

    I also never thought too much about the battery mode; I hadn't changed it since I got the light because I had always used it with CR123A primaries. I guess it does make a difference though.
    yeah that makes sense now that you mention it. 2x 123s if, at 4v, would be already far depleted by the time they hit 4v in total, so i guess i see now
    aka Edgar Allan Bro, Brosama Bin Liftin, Walter Crunkite, Bro Namath, Teddy Brosevelt, and the Tomahawk Crunkmissile.
    my lights - review of PrecisionWorks - that's Gucci Mane in my avatar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •