Olight - S1 - MINI        
Results 1 to 7 of 7

Thread: MAHA MH-C800S Flashes "done" even with no batteries inserted

  1. #1
    Unenlightened
    Join Date
    Feb 2013
    Posts
    1

    Default MAHA MH-C800S Flashes "done" even with no batteries inserted

    This is a weird one:

    When I power my battery charger (MAHA MH-C800S) it runs through the power on self-test, then proceeds to blink/flash "done" repeatedly on all the 8 battery stats indicators.

    Coming from the PC world, I've tried to start the charger holding down the condition button, this shows me a full LCD display of the "amound full" things inside the battery graphic. Starting the charger holding down the "SOFT" button does not appear to do anything.

    I seriously believe that it is a matter of figuring out how to reset the box, but I have not figured out how. Reading about this charger and the 808, which seem to be identical in operation, I was hoping that someone knew a secret combination that I could try - i.e. Since some of the operation of the device revolves around inserting a battery in slot 1, I figured, maybe, there's something similar one has to do to reset the device. Oh, I've tried restart the device with a battery in slot 1 holding both the condition button, the "soft" button and both during power-on, but nothing have helped so far.

    I can certainly produce "odd" behavior, such as starting it with a battery in the leftmost slot, then inserting another battery in slot 2 gives me a "Charging" indicator for slot 3(!)

    I've used Sanyo Eneloop exclusively for this device, and the last thing that I charged before I noticed this behavior was two AAA batteries. I've never done anything else than just insert batteries and wait for them to indicated "done". Also, I tend to leave the batteries in the charger for a long time before I check back on them - the charger is always powered.

    I would hope to have this fixed without having to send anything in. As I mentioned, I hope there is a secret "reset to factory defaults" combination that I can try.
    Looking forward to your answers,

    From Norway,

    Pedro

  2. #2

    Default Re: MAHA MH-C800S Flashes "done" even with no batteries inserted

    I really have my doubts these chargers tend to have any sort of memory that stays set after AC power is removed. In fact, there were threads on this site complaining about the lack of such a memory (since if there's a power outage, the charger won't remember where it left off and might end up overcharging an already full battery).
    If as you this charger is going through a self-test, wouldn't abnormal behavior after that simply indicate it failed that self-test?

  3. #3
    Unenlightened
    Join Date
    Mar 2018
    Posts
    1

    Default Re: MAHA MH-C800S Flashes "done" even with no batteries inserted

    Good morning, Pedro!

    Since has been almost 5 years from this thread, have you already gotten a answer to that? It just happened the same thing to my wife's charger...

    Thanks a lot.

    Carlos

  4. #4
    Moderator
    nbp's Avatar
    Join Date
    Dec 2007
    Location
    Wisconsin
    Posts
    8,675

    Default Re: MAHA MH-C800S Flashes "done" even with no batteries inserted

    The OP hasnít logged in since 2013 and is unlikely to respond, but perhaps someone else has some helpful experiences.

  5. #5

    Default Re: MAHA MH-C800S Flashes "done" even with no batteries inserted

    Support email to Maha would be my first try...

  6. #6
    Flashaholic* ChrisGarrett's Avatar
    Join Date
    Feb 2012
    Location
    Miami, Florida
    Posts
    4,987

    Default Re: MAHA MH-C800S Flashes "done" even with no batteries inserted

    Quote Originally Posted by SweD View Post
    Support email to Maha would be my first try...
    Yeah, that's kind of a no-brainer, if the OP has already done the 'button press' thing.

    Chris
    Convoy: S2, S2+, M1, M2, Fenix: P1D, PD32, HL30, ET: D25C Ti, SF: 6P, ZL: SC-600, Klarus: P2A, Jetbeam: BA-20, Icon: Rogue 1, L3: L10, Xeno: E03, ShiningBeam: I-Mini, Olight: i3s, SWM: D40A, M11R, V11R, Maglite: 6Ds, MMs, Solitaires, LaCrosse BC-700, Maha C-9000, XTAR VP2, MP1S, XP1, MC1+, WP2 II, NiteCore i4, v2.

  7. #7

    Default Re: MAHA MH-C800S Flashes "done" even with no batteries inserted

    Quote Originally Posted by ChrisGarrett View Post
    Yeah, that's kind of a no-brainer, if the OP has already done the 'button press' thing.

    Chris
    Would be interesting to hear how it goes if they are contacted, if they are still siding with customers. The few times I've had reasons to contact them I've received prompt and proper replies. First NiMH charger I ever bought was an MH-C401FS. It started acting up a few years down the line, cooking cells more often than not, habitually missing terminations. I didn't even have to send the old one back, they sent a new one, no questions asked. I did have to pay for shipping but nothing more. Nicely handled by them for an out of warranty item.

    /Dennis

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •