Fenix Outfitters        
Results 1 to 4 of 4

Thread: Xtar VC2 Plus Shows eneloop 1% But Meter Shows 2.1v

  1. #1

    Default Xtar VC2 Plus Shows eneloop 1% But Meter Shows 2.1v

    My Xtar VC2 Plus is showing my eneloop AA @1% capacity with several hrs ETA. My Fluke Meter Shows 2.1v. I this like a car battery that has 12.0 is basically dead?
    Is the eneloop still ok?
    The R/T, The Truck
    O-Light M20 Warrior Premium / Fenix PD32 & PD35 / HID Converted Thor / Cibie 275-S

  2. #2
    Flashaholic* ChrisGarrett's Avatar
    Join Date
    Feb 2012
    Location
    Miami, Florida
    Posts
    4,945

    Default Re: Xtar VC2 Plus Shows eneloop 1% But Meter Shows 2.1v

    Quote Originally Posted by therock View Post
    My Xtar VC2 Plus is showing my eneloop AA @1% capacity with several hrs ETA. My Fluke Meter Shows 2.1v. I this like a car battery that has 12.0 is basically dead?
    Is the eneloop still ok?
    Something's wrong, bro.

    Is the battery in your Fluke good?

    Forgetting for one moment, the "1%" part, 2.1v is way too high for an Eneloop that probably shouldn't ever be a even 1.60v. Do you mean 1.1v?

    The 2.1v isn't while it's charging on the charger, is it?

    Pulsing chargers can pulse at a high amperage, from what I've read here, but those higher pulses are very short in duration.

    Chris
    Convoy: S2, S2+, M1, M2, Fenix: P1D, PD32, HL30, ET: D25C Ti, SF: 6P, ZL: SC-600, Klarus: P2A, Jetbeam: BA-20, Icon: Rogue 1, L3: L10, Xeno: E03, ShiningBeam: I-Mini, Olight: i3s, SWM: D40A, M11R, V11R, Maglite: 6Ds, MMs, Solitaires, LaCrosse BC-700, Maha C-9000, XTAR VP2, MP1S, XP1, MC1+, WP2 II, NiteCore i4, v2.

  3. #3

    Default Re: Xtar VC2 Plus Shows eneloop 1% But Meter Shows 2.1v

    Sorry for the late reply. Its not like me. I do appreciate help.

    Yes, 1.1v and the Eneloop was bad.
    The R/T, The Truck
    O-Light M20 Warrior Premium / Fenix PD32 & PD35 / HID Converted Thor / Cibie 275-S

  4. #4
    Flashaholic*
    Join Date
    Jun 2014
    Location
    Canada
    Posts
    2,369

    Default Re: Xtar VC2 Plus Shows eneloop 1% But Meter Shows 2.1v

    I find Eneloops are very tough. Did the charger kill it, or was it bad from something else?

    Personally, I've never had an Eneloop go bad in 11 years, and I have well over 200 hundred of them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •