Foxfury Scout        
Results 1 to 3 of 3

Thread: Fenix CL25R lantern won't turn on

  1. #1

    Default Fenix CL25R lantern won't turn on

    I bought a new Fenix CL25R LED lantern from MEC in Toronto. I put in brand new button top 18650 battery with + facing up to the top.
    the light never turn on. I tried a flat top battery but it is still dead. I already removed plastic sheet at the bottom screw end.

  2. #2
    Flashaholic Subterrestrial's Avatar
    Join Date
    Jul 2016
    The Mountains (they were calling....)

    Default Re: Fenix CL25R lantern won't turn on

    Are you holding the power button down for 1-2 seconds? If you're doing that and it still doesn't work, contact the vendor.

  3. #3
    Flashaholic* hiuintahs's Avatar
    Join Date
    Sep 2006

    Default Re: Fenix CL25R lantern won't turn on

    In addition to having to hold the button down for a couple of seconds there is possibility of another issue. I purchased one of these lanterns for my daughter who lives in another state and she could not get her lantern to turn on the first we had a little discussion over the phone. I also told her about the plastic sheet which she said she had removed. What her problem was that she did not have the cap screwed on all the way.

    Without a proper connection between the battery or the tail cap, you can still power the lantern on via the USB port. See if the lantern works that way. That at least proves the lantern works. If it does, then its a connection issue. Likely the cap just isn't screwed on all the way. Those caps are kind of stiff. This post is a bit old, but if you ever did get things figured out, let us know.
    Last edited by hiuintahs; 07-13-2017 at 02:07 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts