Fitorch        
Results 1 to 6 of 6

Thread: LED Circuit Help

  1. #1

    Default LED Circuit Help

    I am trying to convert a DeWalt (model DW919) work light to LED. I have the circuit assembled (sub-par diagram pictured here: https://imgur.com/a/PXR6dtH) but when I flip the switch the resistor fries. Did I get a way too small resistor? A little insight on what I did wrong in this circuit would be very helpful.

    Circuit info:
    20V DC source
    1000mA driver (has dimmer, not using)
    One Switch
    3 Cree XP-G2 LEDs in series (one 3up star, Forward voltage @ 1000 mA =3.0v)
    12.4 Ohm resistor

    Thanks all

  2. #2

    Default Re: LED Circuit Help

    Welcome to the forums. Sound like it'll be an impressive light.

    The resistor should not be part of the circuit. I am assuming you meant LDD-1000HW not LDD-100HW.

    There are 5 wires on the driver. The white wire is PWM and can be ignored. The black wire is "V in -" and that goes to the negative of the 20V battery. The red wire is "V in +" and that goes to the switch. The other side of the switch connects to battery positive. The blue wire is "V out -" and that goes to the minus side of the LED array. The yellow wire is "V out +" and that goes to the positive side of the LED array.
    Try the largest, fastest, most flexible flashlight search engine: parametrek.com
    40 brands, 1936 models and still growing!
    NEW: battery search, sleeping pads search

  3. #3

    Default Re: LED Circuit Help

    Quote Originally Posted by parametrek View Post
    Welcome to the forums. Sound like it'll be an impressive light.

    The resistor should not be part of the circuit. I am assuming you meant LDD-1000HW not LDD-100HW.

    There are 5 wires on the driver. The white wire is PWM and can be ignored. The black wire is "V in -" and that goes to the negative of the 20V battery. The red wire is "V in +" and that goes to the switch. The other side of the switch connects to battery positive. The blue wire is "V out -" and that goes to the minus side of the LED array. The yellow wire is "V out +" and that goes to the positive side of the LED array.
    I just tried the circuit without the resistors, and the LEDs didn't turn on, and the driver started smoking (I have more drivers, nbd).

    When I include the resistors (before they start cooking), the lights activate but they cycle (blink) every second. I have limited circuit expertise so this is a head scratcher for me.

    The battery model is a DCB203 if that helps. Thanks in advance if anyone has a solution.

  4. #4
    Flashaholic
    Join Date
    Oct 2016
    Posts
    457

    Default Re: LED Circuit Help

    Quote Originally Posted by harmfulcow View Post
    I am trying to convert a DeWalt (model DW919) work light to LED. I have the circuit assembled (sub-par diagram pictured here: https://imgur.com/a/PXR6dtH) but when I flip the switch the resistor fries. Did I get a way too small resistor? A little insight on what I did wrong in this circuit would be very helpful.

    Circuit info:
    20V DC source
    1000mA driver (has dimmer, not using)
    One Switch
    3 Cree XP-G2 LEDs in series (one 3up star, Forward voltage @ 1000 mA =3.0v)
    12.4 Ohm resistor

    Thanks all
    As noted, no resistor, but you are hooking it up wrong. Note the standard application circuit in the data sheet.

    Vin+ to + on battery.
    Vin- to - on battery.

    Vout+ to LED+
    Vout- to LED-

    DO NOT connect Vout- to Vin- ... as stated not to do in the data sheet.


    Odds are you shorted out the current sensing resistors that are inside the DC-DC convertor, hence the smoke. That one is a throw-away. When you had the resistor, you were still somewhat shorting them out, but the current would only go up to 1A. Other things were happening that caused the flash.

  5. #5

    Default Re: LED Circuit Help

    Quote Originally Posted by ssanasisredna View Post
    As noted, no resistor, but you are hooking it up wrong. Note the standard application circuit in the data sheet.

    Vin+ to + on battery.
    Vin- to - on battery.

    Vout+ to LED+
    Vout- to LED-

    DO NOT connect Vout- to Vin- ... as stated not to do in the data sheet.


    Odds are you shorted out the current sensing resistors that are inside the DC-DC convertor, hence the smoke. That one is a throw-away. When you had the resistor, you were still somewhat shorting them out, but the current would only go up to 1A. Other things were happening that caused the flash.
    V out - is connected to the - LED terminal, V in - is connected to the - battery terminal, V out + is connected to the + LED terminal, V in + is connected to the + battery terminal. I can see where my rather crappy circuit diagram might not have made all that clear. Here is a picture of the wiring without power to the circuit, red and black wires being + and - respectively. There isn't a switch in this one, I just pull the power connection since it is a test setup.

    https://imgur.com/b6jzNdD

    Thanks for all the responses all

  6. #6

    Default Re: LED Circuit Help

    Quote Originally Posted by harmfulcow View Post
    V out - is connected to the - LED terminal, V in - is connected to the - battery terminal, V out + is connected to the + LED terminal, V in + is connected to the + battery terminal. I can see where my rather crappy circuit diagram might not have made all that clear. Here is a picture of the wiring without power to the circuit, red and black wires being + and - respectively. There isn't a switch in this one, I just pull the power connection since it is a test setup.

    https://imgur.com/b6jzNdD

    Thanks for all the responses all

    I figured it out. The problem the whole time was the 20v Dewalt pack had its own power regulating components inside. When I hooked the circuit up to a "dumb" 18v dewalt, it worked just fine. Thanks again for the help guys/gals

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •