The Fenix-Store
Results 1 to 14 of 14

Thread: VIP tailswitch stopped working ??

  1. #1
    Flashaholic*
    Join Date
    Jun 2003
    Location
    Raytown, Missouri USA
    Posts
    617

    Default VIP tailswitch stopped working ??

    My VIP tailswitch stopped responding. Nothing happens except for the click.

    I took off the king's crown and replaced it with the twisty, and it works fine.

    I replaced the Kroll of the king's crown with one from a McLux that was working fine, and it still won't answer the bell.

    How can this possibly happen?

    Help!

    Chuck

  2. #2

    Default Re: VIP tailswitch stopped working ??

    Kroll switches are known to have high failure rates. Just replace it or repair it (I think I read a post about how to do that around here, run a search)

  3. #3
    *Flashaholic* bwaites's Avatar
    Join Date
    Nov 2003
    Location
    Central Washington State
    Posts
    5,044

    Default Re: VIP tailswitch stopped working ??

    This has got to be a tailcap/kroll interface issue.

    The Kroll has some interesting issues on its own, so it doesn't surprise me that your seeing this.

    When I get home I'll pull mine out and check it, but I have heard others mention a similar problem in the past and I'm sure Charlie will log in shortly with the cure.

    Bill

  4. #4
    Flashaholic*
    Join Date
    Jun 2003
    Location
    Raytown, Missouri USA
    Posts
    617

    Default Re: VIP tailswitch stopped working ??

    [ QUOTE ]
    sygyzy said:
    Kroll switches are known to have high failure rates. Just replace it or repair it (I think I read a post about how to do that around here, run a search)

    [/ QUOTE ]

    Yeh, I know about the notorious Kroll first hand. I did replace it - with one that was already known to work (the McLux). And, I also took it apart to see what was wrong with it...nothing was wrong that I could see. I even put it back in the McLux, and it worked there as before, but not in the VIP.

    This doesn't make sense at all - especially when it has been working fine until just now.

    Thanks for your ideas everyone.

    Chuck

  5. #5
    *Flashaholic* bwaites's Avatar
    Join Date
    Nov 2003
    Location
    Central Washington State
    Posts
    5,044

    Default Re: VIP tailswitch stopped working ??

    The VIP board is VERY sensitive to resistance issues if I recall correctly.

    Check all the contact points to make sure that there is a good aluminum to aluminum contact.

    Also did you remove the sponge rubber donut used with the twisty?

    Bill

  6. #6

    Default Re: VIP tailswitch stopped working ??

    Hi Chuck! Your holiday season is going just great I see!

    But seriously, if you replaced the Kroll with a known functional one and it still does not work in the VIP yet the Twisty does(???), then you do indeed have a contact/resistance issue in the King's Crown tailpiece somewhere. I would invest in some Caig's ProGold (must be L100, no lesser numbers!) and follow the directions. It is basically a contact cleaner that you apply (comes in various formats such as needle dropper, brush-in-bottle, felt tip pen, etc.) on the affected surface/s (I would hit ALL the contact points/joints of the light since you'll be into it anyway) and then wipe off. You will usually get a nice black grunge after which you repeat until the cloth or whatever you use comes off clean, then a Very Sparing final application before screwing the parts back together.

    If it STILL does not work then just send it back for a free service. All MR Bulk lights are Bulk-backed to the original purchasers (for a reasonable period of time, of course) - then again maybe I'm just in a holiday mood and will forget all about this come the new year (quick, send it now!)...seriously though, the Caig's will work wonders. Also very useful for stereo equipment contacts, VCRs, etc. And in even some of the really grunged-over poorly performing incandescents, cleaning the contacts makes them absolutely blast out the photons, visibly to the eye which means they become at least twice as bright. A good investment for all things electrical and not just the VIP.

    Their webstore is HERE.

    Let me know how you make out.

  7. #7
    Flashaholic*
    Join Date
    Jun 2003
    Location
    Raytown, Missouri USA
    Posts
    617

    Default Re: VIP tailswitch stopped working ??

    Charlie:

    Thanks for the suggestions.

    You are right about my luck. In fact, I am heading off to the clinic right now to have another EGD, which is where they stick this thing down my throat and inflate it to break a constriction right above my stomach.

    Back to the VIP: I clicked on the link that you provided. I got to their website alright, but they do not list a product that goes by "L100". It appears that they used to carry "ProGold GxL", but that has been changed to just "ProGold". Under that list I found products such as "ProGold ® G100L Needle Dispenser, 100% solution, 25 ml, Part No. G100L-25C". They offer a long list of different product numbers under ProGold. (The one thing they all seem to have in common is that they are all expensive.)

    Do you think this is the same as your "L100"?

    Would Radio Shack contact cleaner work?

    Thank you,

    Chuck

  8. #8
    Flashaholic* gregw's Avatar
    Join Date
    Jun 2004
    Location
    Hong Kong
    Posts
    1,511

    Default Re: VIP tailswitch stopped working ??

    Chuck,

    Sorry to hear about the EGD. [img]/ubbthreads/images/graemlins/frown.gif[/img]

    Regarding the ProGold, you'll want the 100% solution, and the smallest quantity available is the 2ml ProGold ® G100L Squeeze Tube

    I had the same problem with my VIP before and had sent it back to Charlie for one of his free VIP Checkups, but decided that it would eventually be cheaper for me to buy some Caig ProGold and do my own servicing. [img]/ubbthreads/images/graemlins/smile.gif[/img]

  9. #9
    Flashaholic*
    Join Date
    Jun 2004
    Location
    Southern California
    Posts
    993

    Default Re: VIP tailswitch stopped working ??

    Thanks gregw. Is that the cheapest? Is there anything else that is cheaper that works almost as good?

  10. #10
    Flashaholic* gregw's Avatar
    Join Date
    Jun 2004
    Location
    Hong Kong
    Posts
    1,511

    Default Re: VIP tailswitch stopped working ??

    Other cleaners I tried didn't work, or worked only for a short period. I bought the 7.4ml bottle of Caig ProGold G100L from PartsExpress which is a few dollars cheaper than buying from Caig directly. Unfortunately, they don't have the 2ml squeeze tube, so that's still the cheapest option if you only want a little bit for the Kroll on the VIP.

  11. #11

    Default Re: VIP tailswitch stopped working ??

    Chuck, so sorry to hear of the health problem. Sucks having it at this time of year especially.

    As for the ProGold, yup, them guys must have an alien galactical patent on it or something, nothing else really works as well to my experience. And the bright side to the expense is that a lil' dab'll do ya, so even the 2ml size goes a long way.

    Take care, kind sir...

  12. #12
    Flashaholic*
    Join Date
    Jun 2003
    Location
    Raytown, Missouri USA
    Posts
    617

    Default Re: VIP tailswitch stopped working ??

    Good news - the switch is working again. I used some cleaner I already had.

    Thanks, everyone for the help! [img]/ubbthreads/images/graemlins/happy14.gif[/img]

    Merry Christmas,

    Chuck

  13. #13
    Flashaholic*
    Join Date
    Jun 2004
    Location
    Southern California
    Posts
    993

    Default Re: VIP tailswitch stopped working ??

    Thanks for the links guys, and the hints. Sounds like amazing stuff. (See I knew Charlie was woking with alien technology to make those lights.) [img]/ubbthreads/images/graemlins/smile.gif[/img]

  14. #14
    Flashaholic
    Join Date
    Jul 2002
    Location
    Florida
    Posts
    307

    Default Re: VIP tailswitch stopped working ??

    I picked up some Pro gold Yesterday at Radio shack.
    This stuff realy works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •