2800 Lumen EDC. Lumintop FW3A

vestureofblood

Well-known member
Joined
Jun 19, 2008
Messages
3,157
Location
Missouri
Hi all,

This turned out to be a great EDC, one of my new favorites for sure.


How does the FW3A compare with your other EDCs?
 

id30209

Well-known member
CPF Supporter
Joined
Mar 7, 2008
Messages
2,715
Location
Croatia, EU
Great review Matt! Of all reviewers out there, yours are the best. All the details and outdoor (walking in the night) shoots are ultimate.
 

savumaki

Well-known member
Joined
Jan 27, 2005
Messages
674
Location
Temagami, ON
Great looking light with fanrastic performance specs. The problem I see is the unprotected battery. I researched supply for another light I had my eyes on and wow did I have an eye opener; supply is spotty and shipping costs put the end price thru the roof. I would jump at one if it came with the bat.
 

JimIslander

Well-known member
CPF Supporter
Joined
Mar 4, 2012
Messages
415
Great looking light with fanrastic performance specs. The problem I see is the unprotected battery. I researched supply for another light I had my eyes on and wow did I have an eye opener; supply is spotty and shipping costs put the end price thru the roof. I would jump at one if it came with the bat.

Is that a Canada thing? Some of the best unprotected batteries are readily available on the internet for 6 bucks a piece. Is it the shipping thing or the import tax that's getting you? Seems like you could buy one from a member or eBay or something, but what do I know I don't live in Canada.
 

savumaki

Well-known member
Joined
Jan 27, 2005
Messages
674
Location
Temagami, ON
I think it is shipping; I can get reasonable prices and then they throw shipping at you. O well, minor problems.
Still a great light and I do have one on the way now.
 

Flamingobadass

New member
Joined
Sep 14, 2019
Messages
1
Fw3a factory reset not working

I can't seem to get my fw3a to factory reset, should be really easy but it's not working. on the fw3a it's supposed to be 13 clicks and you hold on the last and I've tried that multiple times, nothing happens. then I've tried the unscrew tail and screw back on while holding tailswitch. that didn't work either and I do not know what to do.
 
Top