Acebeam L16 Issues - anyone experience them?

R

RCLumens

Enlightened
CPF Supporter
Joined
Oct 5, 2011
Messages
417
Location
Cape Cod, MA
Greetings to all, Am posting a thread regarding my acebeam L16. As of recent, the light decides to shut off unexpectedly. From all modes, random times, and yes battery has been fully charged and seems to be in good condition. This said, maybe there is something wrong with battery or maybe something in the light?? It's not a shelf queen by any means, but is not abused either. Mostly for night time yard scoping.

I saw this post on reddit which is the only thing I found in comparison, and I'm having what seems to be the same issue. Wondering if any owners especially longer term as I've had mine about a year has experienced this and possibly resolved?

Many thanks in advance and best to all
RC
 
SCEMan

SCEMan

Flashlight Enthusiast
Joined
Nov 6, 2005
Messages
1,544
Location
Treasure Valley, ID
RC:

I haven't experienced any issues at all with my L16 using numerous batteries. It hasn't seen a lot of use lately with DST in effect. Hope you find a solution as it's one of my favorite lights.
 
easilyled

easilyled

Flashaholic
Joined
Jun 25, 2004
Messages
7,254
Location
Middlesex, UK
Have you tried a different battery to make sure that it's not the battery that's at fault?

That would be the first thing I'd do.
 
R

RCLumens

Enlightened
CPF Supporter
Joined
Oct 5, 2011
Messages
417
Location
Cape Cod, MA
**UPDATE** Firstly, thank you for the responses, suggestions and views. Possible resolution and will update post title in a couple weeks just to make sure. The cigar grip part was loose. JUST A LITTLE BIT. But there was about 1.5 to 2 rotations on threads to fully tighten. Last night was my first attempt at using and no problems to report. This said, given the sudden appearance of the issue, the battery was an initial thought. Yet the light and guessing battery condition are not heavily used/ abused. Also i have an l30 and x65, and so I've had no issues with either of those. Will update post either way after some repeated use. Also to note, the l30 cigar ring spins at its designated area, and nothing to tighten. It's the v2, so maybe new design because of the potential to disrupt contact? Im no expert just speculating. Many thanks and health to all
 
SCEMan

SCEMan

Flashlight Enthusiast
Joined
Nov 6, 2005
Messages
1,544
Location
Treasure Valley, ID
The cigar grip part was loose. JUST A LITTLE BIT. But there was about 1.5 to 2 rotations on threads to fully tighten.

Hmmm. That might be it. I removed the "cigar ring" on my L16 so I can't comment on that issue. I have had similar issues with my Quarks when the belt clip retaining ring was loose.
 
Top