FandyFire STL-V6 not working.

Status
Not open for further replies.

Rikr

Newly Enlightened
Joined
Jun 1, 2011
Messages
154
Location
High Ridge, MO
Well another great day... I got my FandyFire STL-V6 and it don't work. I have checked everything, it came on once and I turned it off and now it just comes on for a second when I push the switch then it goes off....Come on can't I get a break. Any ideas??????
 

Mike_TX

Enlightened
Joined
Oct 26, 2009
Messages
225
Well another great day... I got my FandyFire STL-V6 and it don't work. I have checked everything, it came on once and I turned it off and now it just comes on for a second when I push the switch then it goes off....Come on can't I get a break. Any ideas??????

Bad tailcap? Try disassembling and checking for ground. Sometimes it's just a matter of tightening the switch module.

.
.
 

Rikr

Newly Enlightened
Joined
Jun 1, 2011
Messages
154
Location
High Ridge, MO
I did all that even took it out and looked at it. The only thing I see is when you take the battery tube out and look at the pill??? I see scratches. How do you get that out? Thanks for your reply.
 

Rikr

Newly Enlightened
Joined
Jun 1, 2011
Messages
154
Location
High Ridge, MO
I took the tailcap apart and I sprayed WD-40 on it then I cleaned all the threads then took the air compressor and blew all items out, and it still does the same thing. How do I get a new switch from DX?
 

Mike_TX

Enlightened
Joined
Oct 26, 2009
Messages
225
There's a process for getting an RMA and returning defective products to DX. That's probably what I'd do at this point. If you mean getting a new tailcap, just search DX for tailcaps or switches.

.
.
 

Rikr

Newly Enlightened
Joined
Jun 1, 2011
Messages
154
Location
High Ridge, MO
Hey 2100, I did that and the light comes on, so I know it's the switch. I emailed DX 4 times yesterday and still no reply. Are they as bad as Manafont?
 

2100

Enlightened
Joined
Apr 4, 2006
Messages
897
Location
SINGAPORE, South East Asia
Hey 2100, I did that and the light comes on, so I know it's the switch. I emailed DX 4 times yesterday and still no reply. Are they as bad as Manafont?
Don't email, just open a case. I did that before, pretty ok. But seriously it's easy to solve so that's lucky for ya, just get another switch that's similar. You probably have another light to experiment with.
 

Juan334

Newly Enlightened
Joined
Aug 21, 2011
Messages
63
Try a non protected battery I had this problem with my c8 XML protection kicked in after it was on for a second and poop off

Sent from my SAMSUNG-SGH-I777 using Tapatalk
 

DM51

Super Moderator,
Supporter
Joined
Oct 31, 2006
Messages
13,338
Location
Borg cube #51
If we allowed a thread for every light bought from DX that failed, this forum would be totally swamped. Please take the issue up direct with them.

Thread closed.
 
Status
Not open for further replies.
Top