is my Ultrafire 602 dead?

Turbo_E

Turbo_E

Enlightened
Joined
Jan 25, 2005
Messages
322
my flashlight from Quality china Goods is no longer lighting up brightly. the led die is just faintly glowing. i was using the 14500 lithium battery. its recommended on their website. BTW its the 3 W unit.

so is this a sign its dead or just something loose?
 
Last edited:
lasercrazy

lasercrazy

Flashlight Enthusiast
Joined
Mar 24, 2004
Messages
1,178
Location
NJ, USA
Did you try changing or charging the battery?
 
Turbo_E

Turbo_E

Enlightened
Joined
Jan 25, 2005
Messages
322
yep, same result with either 3.7V or a 1.2 V and 1.5 V :(

I'm thinking of getting Fenix P1 to replace it. Does it have multi briteness or just one level?
 
L

Lee1959

Flashlight Enthusiast
Joined
Nov 18, 2005
Messages
2,020
Location
Michigan
The P1 is single level currently. It is a nice light however, my wife loves hers.
 
H

havand

Enlightened
Joined
Jun 7, 2006
Messages
607
Location
Pa, U.S.
Turbo_E said:
my flashlight from Quality china Goods is no longer lighting up brightly. the led die is just faintly glowing. i was using the 14500 lithium battery. its recommended on their website. BTW its the 3 W unit.

so is this a sign its dead or just something loose?

If you decide not to mod it and wanna sell it for cheap, I might be interested. Send me a PM if you do :)
 
IsaacHayes

IsaacHayes

Flashlight Enthusiast
Joined
Jan 30, 2003
Messages
5,876
Location
Missouri
I'll take it if the price is right for mod fodder! :)

Perhaps the led got cooked? I wonder if the circuit is still putting out full power?
 
H

havand

Enlightened
Joined
Jun 7, 2006
Messages
607
Location
Pa, U.S.
IsaacHayes said:
I'll take it if the price is right for mod fodder! :)

Perhaps the led got cooked? I wonder if the circuit is still putting out full power?

*Cough* Dibs called above, *Cough*

:naughty::p
 
IsaacHayes

IsaacHayes

Flashlight Enthusiast
Joined
Jan 30, 2003
Messages
5,876
Location
Missouri
(@*#&*($23 you beat me by a few seconds!!!!!!!!!

GRRRRRR :rant: Hmm. I must be getting slower!!! :)
 
Turbo_E

Turbo_E

Enlightened
Joined
Jan 25, 2005
Messages
322
i swapped in a tbin 3 watter. works well with the 3.7 V lithuim. the anodizing is pretty beat so i dunno if you guys still wanna buy it.

i ordered a LOP Special edition today.
 
IsaacHayes

IsaacHayes

Flashlight Enthusiast
Joined
Jan 30, 2003
Messages
5,876
Location
Missouri
hmm. I guess chalk it up to cheap luxeon clones can't take the heat!! :)

Now it's got a true luxeon it should last as long as heatsinking is decent.
 
Turbo_E

Turbo_E

Enlightened
Joined
Jan 25, 2005
Messages
322
well if i remember correctly, they used a overdriven 1.5W unit cuz when it runs off a 3 watt unit, with a 1.5V batt its pretty dim.
 
IsaacHayes

IsaacHayes

Flashlight Enthusiast
Joined
Jan 30, 2003
Messages
5,876
Location
Missouri
Well, then it seems the circuit may be damaged as well then. A luxeon1/3 should not matter, they should both be close to the same light output when driven the same. Unless your luxeon3 you put in there has a super high voltage forward or something wierd like that.

And all the ultrafires I've seen had clone luxeons in there. They weren't true luxeons. Pretty bright though. I never put li-ions in there though. Some ultrafire have Seoul Z-led's in there which should be pretty durable, but the beam color is a little un-even...

I'm guessing something is wrong with the circuit then if it's pretty dim with 1.5v battery....
 

Similar threads

berto
Replies
3
Views
1K
Walt175
W
J
Replies
7
Views
2K
jasonsmaglites
J
H
Replies
6
Views
1K
cmaylodm
C
R
Replies
18
Views
3K
river251
R
abvidledUK
Replies
1
Views
922
jmw19
J
Top