LumaPower IncenDio v3 behavior differs from the manual's description

flatline

Flashlight Enthusiast
Joined
Jul 6, 2009
Messages
1,926
Location
Tennessee
Several years ago I got a LumaPower IncenDio v3 in a trade and I've used it ever since with diffuser as a reading light. I was cleaning the other day and found the box it came in with the instructions and I took a moment to read them and discovered that my light's behavior doesn't agree with the documentation.

Specifically, the instructions say the light has 3 modes: L-M-H. But my light appears to have 4 modes: L-M-H-T (I'm guessing it's turbo, but I can't really tell a difference between H and T).

The other thing is that the instructions clearly state that the light can use a RCR123A. The instructions give no indication that the light should behave differently when using an RCR123A, but when I put one in, the light becomes a 1-mode light that is brighter than the brightest mode available when using a CR123A.

Does anyone know if this is normal for the IncenDio v3 or is my light somehow different from the regular model?

--flatline
 

lebox97

Enlightened
Joined
Jul 27, 2005
Messages
697
Location
illuminationGear
the last versions we had were V3+ & V3X,
not sure which specific version you have:

"
IncenDio V3U+(CREE XP-G2 R5)
250 Lumens
(using 1xCR123) /

420 Lumens (using 1xR123/16340)


IncenDio V3X (CREE XM-L2 U2)2014 Model
380 Lumens
(using 1xCR123 Lithium Battery) /

610 Lumens (using 1xR123/16340 Li-ion Battery)
(WARNING: Do NOT run light on 500+ lumen mode for more than 1-2 minutes at a time - LED and/or battery damage can occur

4-Mode - 3%, 15%, 40%, 100%

"

the quickest simplest solution would be to contact LumaPower directly.
http://lumapower.com/Contact_Us.html

Cheers
 
Top