Lumintop TD15 memory problem?

TapouT

Newly Enlightened
Joined
Nov 4, 2009
Messages
17
Location
Ohio
I like this light and it has great throw (best light i ever owned), but I am having some problems with it already.



While the light was in the highest output mode (420 lumen) and in memory, one of the times when i went to strobe it instead switched the mode regular and was in now in its lowest lumen.



Then a minute ago I was outside and when I twisted the head to go into strobe it went into strobe mode but then quickly started to dim in strobe and when I went back off strobe by tightening the head it went to the reg. mode and was now in the lowest lumen like before.



Both times the light was in tactical mode highest output and stored in memory. It is still bright as heck (except for that dimmed strobe spurt) so I wouldn't think battery.



Anyone know what might be going on?
 

DLite57

Newly Enlightened
Joined
Apr 20, 2011
Messages
33
Location
New Haven, CT
I have a TD15 that I also just love & have had no problems with the UI. What memory problem are you referring to, as it has 5 modes. Max, strobe, then 2 quick twists bring you to low, medium, high (maybe not in that order?). Wasn't aware that you could "program" anything.
As I said, my light has been flawless. I set it up with 2 extenders to run off 2 18650's, for longer run-time. A little big, but works great. I made a hole carefully in the bottom of the holster so the light could extend out, but catches on the knurling to keep from dropping.
Am interested in more replies to any issues?
Jeff:thinking:
 

DLite57

Newly Enlightened
Joined
Apr 20, 2011
Messages
33
Location
New Haven, CT
What batteries are you using? I have found that CR123s can affect these issues if low on power. The reason I only use 18650s. You have to be careful when twisting the head, being sure your movements are quick. Sorry about missing some of your post. 18650s seem to work best when given the option.
Hope this helps. Had a similar issue on my JET-III Ultra using CR123s. The UI went wacky when the batteries got low.
Jeff
 

DLite57

Newly Enlightened
Joined
Apr 20, 2011
Messages
33
Location
New Haven, CT
Forgot to mention that the "memory" you're referring to is that the light retains the last mode used when turned off. Turn it back on, same mode. As I said & have experienced, twisting must be done quickly. So, might not be a battery issue, but just getting used to the light. A learning process, but a great light!
Jeff
 

herosemblem

Enlightened
Joined
Apr 2, 2011
Messages
355
Location
Yolo, CA
I also experience a "memory" problem with my TD15, although I'm not sure it's the same problem as yours, Original Poster.
I use my TD15 only in Turbo mode. (AKA turbo/strobe...I never use strobe btw).
Here's what occasionally happens:

I pull the light out of my pocket, I either soft-touch or click the button (doesn't matter which), and instead of turning on in turbo, the light turns on in Low. The light is now in multi-level mode, without me having prompted the light to do so.
Then I have to do the double-twist trick to get the light back into Turbo mode.

I suspect this phenomenon happens when the two CR123 batteries are below ~65%.
~~~~~~~~
Now, when the batteries are actually low, then yes, I'll turn the light on in Turbo mode, and after 4-10 seconds the light automatically switches to Low mode. That's fine and expected, due to low batteries.
Or, sometimes when the batteries are also low, the light will simply default to High, and turning it to Turbo will only last maybe 15 seconds before it reverts to High.
This is also expected, due to low batteries.

Yes, the threads and contacts are clean.
Not the most reliable, but I still use it 5 days a week because of its brightness and pocketability (pocket size+clip).
 

Latest posts

Top