Olight S15R (XM-L2, 1x14500/AA) Rechargeable + Dock Review: BEAMSHOTS, RUNTIMES+

WarRaven

Flashlight Enthusiast
Joined
Oct 24, 2013
Messages
2,135
Location
Edmonton, Alberta
I hear you, they need a new representative though.
Ignoring customers after sale like they did for a long time with the S30R users is very damaging to not only my outlook on future purchases of their wares, of others too.

This is beyond frustrating to me already dealing with Olight.
Love the lights, despite their customer service.

Edited autocorrected word.
 
Last edited:

Flashy808

Enlightened
Joined
Jul 2, 2015
Messages
281
Hmm never knew that thanks. I also like there style of lights but never thought that supplier could be so bad on CS, like if they want to sell there products they should at least be bothered with CS.

Back on topic, does the S15R come with a battery extension tube or is that just the S15?
 

X5CR123A

Newly Enlightened
Joined
Feb 7, 2007
Messages
18
I bought the extension tube separately for my S15R, for use with AA NiMH if the single li-ion goes flat
 

Flashy808

Enlightened
Joined
Jul 2, 2015
Messages
281
I was thinking about purchasing a extension tube (after reading your great review :)) but the fact that you could only use it for AA/NiMHs was a real bummer.
 

Frank W

Newly Enlightened
Joined
Dec 17, 2013
Messages
20
Location
Europe
Just asking, since I had my tailcap replaced under warranty after e light broke down, what is the issue and talk about S30II? Is my replaced tailcap on the S15R going to fail again, ie was there some general issue with it, or just bad luck? The importer changed the failed tailcap, but if it was some general problem with the, failing over time I would like to sort it out for once and all...
 

WarRaven

Flashlight Enthusiast
Joined
Oct 24, 2013
Messages
2,135
Location
Edmonton, Alberta
Hi Frank
The Olight Rep told me that my delay was them re engineering tail cap so it would not jam itself up anymore.(Not sure I believe)
So the likely hood of your cap failing again is down to, if the seller gave you a cap off of another light in stock or, got one of these new versions.
I still have not received replacements for mine to date.
If yours gets jammed up again, I guess we'll know which you got.
 

Flashy808

Enlightened
Joined
Jul 2, 2015
Messages
281
Hi Frank
The Olight Rep told me that my delay was them re engineering tail cap so it would not jam itself up anymore.(Not sure I believe)
So the likely hood of your cap failing again is down to, if the seller gave you a cap off of another light in stock or, got one of these new versions.
I still have not received replacements for mine to date.
If yours gets jammed up again, I guess we'll know which you got.

Guess so. Manufacturers should so make sure there QC is too notch it means quite a lot to their further with us.

Also just got word from Xtar CS after about 2 months! ;)

Oh and thanks for clarifying SelfBuit! :)
 

WarRaven

Flashlight Enthusiast
Joined
Oct 24, 2013
Messages
2,135
Location
Edmonton, Alberta
I have to update my sour posts☺
Parts were in mail yesterday waiting for me when I got in.
As mentioned, they are new style. Obvious retaining ring inside difference from earlier design doing just a visual. Functions as expected.
 

selfbuilt

Flashaholic
Joined
May 27, 2006
Messages
6,936
Location
Canada
How long does it take to charge the battery using the dock?
On the first generation tested here, it took 2hr 20min to charge to ~4.15V. Currently shipping models probably take an extra 20 mins or so to make it to ~4.2V.
 

X5CR123A

Newly Enlightened
Joined
Feb 7, 2007
Messages
18
I think selfbuilt is saying the later models have a higher cut off voltage. More capacity in would take longer.
 

selfbuilt

Flashaholic
Joined
May 27, 2006
Messages
6,936
Location
Canada
I think selfbuilt is saying the later models have a higher cut off voltage. More capacity in would take longer.
Yes, on a CC/CV charging algorithm (which the S15R seems to approximate pretty well), those last ~0.05V can take awhile to reach, since the current is quite low by then.
 

Danielsan

Enlightened
Joined
Aug 24, 2010
Messages
398
Location
Germany - Darmstadt
The low voltage warning indicator behind the power button is not working. I have it from gearbest, i hope my s30 i ordered have a working indicator.
 

dvlad666

Newly Enlightened
Joined
Nov 10, 2015
Messages
1
Thanks dear selfbuilt and other S15R owners for your reviews!

Could you please tell how does this light behave while docked and with NO battery inside? I'm especially interested in:
-Are all Lo, Med, Hi modes available? (as for Hi i doubt due to the charger current being limited)
-Does the mode memory function work if 5V dock input is lost?
-What is the longest intermittent power loss at the ring the light can survive with no notice? Say, if its rotated at the base or accidentially inclined by the hand

I have read the whole thread for answers but came up empty

Thanks a lot in advance!
 

selfbuilt

Flashaholic
Joined
May 27, 2006
Messages
6,936
Location
Canada
Could you please tell how does this light behave while docked and with NO battery inside? I'm especially interested in:
It doesn't work that way - the dock simply charges the battery, it doesn't allow the light to operate without a battery installed.
:welcome:
 

funkychateau

Enlightened
Joined
Apr 6, 2009
Messages
274
Location
Dallas, Texas, USA
At what voltage did the low-voltage indicator illuminate for eneloop, alkaline, and Li-ion batteries? And did this readjust itself when using 2x eneloop or 2x alkaline?

thanks!
 

Frank W

Newly Enlightened
Joined
Dec 17, 2013
Messages
20
Location
Europe
Hi Frank
The Olight Rep told me that my delay was them re engineering tail cap so it would not jam itself up anymore.(Not sure I believe)
So the likely hood of your cap failing again is down to, if the seller gave you a cap off of another light in stock or, got one of these new versions.
I still have not received replacements for mine to date.
If yours gets jammed up again, I guess we'll know which you got.

Hi, thanks for the info. My (old version) replacement cap failed as well, so my rep just got me one from what he said was was the new batch which they finally got in stock. We will see :)
 

Flashy808

Enlightened
Joined
Jul 2, 2015
Messages
281
Today I tried to use an Apple USB Power adaptor to charge my S15R and the charging-dok came up with a fast flashing (no, not the slow one as mentioned in SelfBuilt's review :grin2: red LED indicator. Then I swapped the adaptor to another Apple adaptor because I thought something was wrong with that one's specifications :popcorn: and I did that multiple times to the point I was about to ask CPF. But then I tried a standard cheap brand USB adaptor and this time it came up with the a constant red (meaning charging properly).

I have heard on some occasions Apple's special coding may interfere with charging but I'm not exactly sure what happened in my case. Could someone please shed some light?:candle: :shakehead

Also would I have damaged my battery? :shakehead

Thanks!!
 

Latest posts

Top