Problem with LED mini mag...

mountaindewer

Newly Enlightened
Joined
Apr 24, 2013
Messages
72
I've had my mini mag (2xAA) for about a year now, and here recently it's been giving me problems. When you turn it on, which is supposed to be high, sometimes it will be very dim, and you have to slap it to make it go bright. sometimes it will flicker and carry on and you have to smack it to fix it. I've taken the head off, and made sure their wasn't nothing inside keeping it from being pushed up when you twist the head to turn it on. and it was clean. i took the battery holder piece off and cleaned it and made sure it was getting good connection and everything is nice and shinny. I'm about to slaps away from slapping it in the trash can! it also does it on low to. sometimes it gets so dim on low, you can't even hardly tell it's on. smack it, and it fixes it, then when you try to walk or move it, it starts again.
 

edpmis02

Enlightened
Joined
May 13, 2008
Messages
204
Location
Northern Va
My three LED minimags (2 are Rebel based) run terribly on NiMh/Eneloops. They are fine if freshly charged, but after a short time or sitting, they get stuck on low mode or flicker. The driver seems to want higher voltage during turn-on than rechargeable batteries deliver. I cleaned mine inside and out several times, and it just seems to be my personal conclusion. I have not tried Energizer lithium primaries.
 

mountaindewer

Newly Enlightened
Joined
Apr 24, 2013
Messages
72
I only use energizer alkalines, you have a point with rechargeable being only 1.2 volts, but it does it even with new alkalines pushing 1.5 volts.
 

edpmis02

Enlightened
Joined
May 13, 2008
Messages
204
Location
Northern Va
I pulled the little spring out of the tailcap and cleaned the underside of it with alcohol along with a sticking a cotton swab onto a pencil to get the + contact clean. I love the size/cost/utility of mine (got one for $4 at a target clearance) but found the issues too annoying to deal with.. so they all sit unused.
 

Frijid

Enlightened
Joined
Feb 26, 2013
Messages
439
Location
USA
along with a sticking a cotton swab onto a pencil to get the + contact clean.


when you did that, did you use a dry ball, or did you put any alcohol on the ball? I've never cleaned the + end on any of my lights, and just curious how to do it.




+1 what everyone else said, about stretching the spring a little. Don't do it so far that it stretches outta shape, just do it a little bit. i also had to do this on mine a few months ago.
 

mountaindewer

Newly Enlightened
Joined
Apr 24, 2013
Messages
72
hmm, now that you all mention it, when it was new, and i would turn the head, i would hear the spring make a noise. Now that it's acting up, i turned the head again, and i can't hear the spring make any noise. I'll give it a good stretch and come back with the results!
 
Top