Angryfox        
Results 1 to 13 of 13

Thread: Fenix L1D/P2D Rebel flashing while mode-changing?

  1. #1

    Default Fenix L1D/P2D Rebel flashing while mode-changing?

    Hi:

    I obtained a Fenix L1D premium/Rebel edition. I have tested it with a AA and with a single CR123A using a P2D body.

    In either case, when first turned on, the light first flashes brightly (appears to hit full "turbo" brightness for a fraction of a second), then settles to it's initial low brightness setting (non-turbo bezel setting, of course). The overshoot flashes also occur when changing to the medium and high modes, then back again to low (after the stupid SOS). Of course, it isn't as noticeable when switching to the higher settings, but it occurs on all mode switches.

    I find this disturbing. If one doesn't want bright light and desires the initial low setting, this flash will knock their socks off in a dark adapted situation. Besides, it smells to me of questionable regulator design.

    I also bought a Cree WC Q5 Fenix PD2 head. This Cree head doesn't have the initial overshoot/flash, nor does it overshoot when changing brightness settings. In fact, it has a remarkably smooth transition between modes. This is a bummer because after comparing the two, I like the Rebel LED's color rendering much better than the Cree (though the Cree isn't too bad).

    So if the Rebel head wasn't flashing like this, I would keep it and perhaps not the Cree head. Now I am not sure what to do.

    If it is common experience that these Rebel (or Cree) heads flash like this, I will return it for refund as "unsatisfactory". If others' heads do not flash at all, I will attempt to exchange for a Rebel that doesn't flash.

    Does anyone else have a flashing/overshooting Fenix P2D, L1D, or L2D head?

    Thanks for input.
    ________
    Good day!

  2. #2
    Enlightened
    Join Date
    Oct 2007
    Location
    Luleå, Sweden
    Posts
    39

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    I can only speak for my one L2D-Q5 which indeed does the flashy-thingy when turning on and changing modes. Also, something I never thought I would say, it is almost too bright even at the lowest setting. It is a bit anoying but nothing I can't live with. (for the moment at least, I might just have to get yet another light to compensate )

  3. #3
    Flashaholic mbirds's Avatar
    Join Date
    Jun 2006
    Location
    Virginia
    Posts
    117

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    I have the flash when turning on with my L2D Q5 that I got yesterday, but not between levels. It doesn't seem to be full turbo, but it's hard to tell. A bit annoying but doesn't bother me too much. I wouldn't mind a solution though.

  4. #4
    Flashaholic
    Join Date
    Feb 2007
    Location
    Germany, Rhein-Main
    Posts
    249

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    my P2D does also flash on low for a fraction of a second but not when modes are changed. to be honest, I don't care about the flash at all, its simply of no importance to me.


    regards, holger

  5. #5

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    Quote Originally Posted by cal..45 View Post
    my P2D does also flash on low for a fraction of a second but not when modes are changed. to be honest, I don't care about the flash at all, its simply of no importance to me.


    regards, holger
    My P2D Q5 does that too, I almost only use mine on turbo, so not a big thing to me, great light

  6. #6
    Flashaholic*
    Join Date
    Dec 2006
    Location
    US of A
    Posts
    1,655

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    My P4 L2D Cree flashes some, my Rebel 100 L2D flashes a lot more, but my Q5 L2D Cree does not flash.

  7. #7

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    My L2D Premium RB100 does this flashy thing too when turning ON to the low power and I imagine from what I have heard that the L2D Premium Q5 I have just ordered will too. But this is not an issue for me - I simply could not care and anyway, I almost always use turbo.

    It will be interesting however to see if the flashy thing also occurs when I use the 1xAA body tube I have also ordered. Interesting - but of no consequence (for me anyway).
    EagTac M25C2 Turbo_VN_XPG2-PDTc version; SureFire UB3T Invictus; Nitecore SRT7; TrustFire X6; LumaPower MVP (3xCree) , Sunwayman V11R; 4Sevens Quark AA Tactical; Nitecore DI (R2, GDP, Q5); LiteFlux LF2XT-R2;

  8. #8
    Flashaholic*
    Join Date
    Sep 2006
    Location
    Maybe Wisconsin, maybe near Nürnberg
    Posts
    1,409

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    FWIW, I just purchased the Fenix PowerPack Christmas Special of a P2D head and body and with a spare L1D body, plus case and diffuser. The P2D-Q5 head does not have the pre-flash. Early in the year I purchased one or more of the following L1D, L2D, and P2D in either Cree or Rebel versions, none of them had a pre-flash. Then late in the year I made a similar purchase - all of them had a very objectionable pre-flash, all were returned. The problem is that Fenix had a batch of LxD and P2D heads that had a pre-flash in the order of 1/10 second, whereas the batches before/after that batch did not have any pre-flash, or maybe something in the order of 1/100 sec. On the basis of what I have read on CPF as well as my own experience, the problem has been corrected to little or no pre-flash. Some users report that they have to look for the pre-flash to see it now.

    BTW, The underlit (sic) surprise of the Fenix-Store line-up for me is the diffuser for the P2D et.al. head. The diffuser is actually quite effective for a near-field even illumination such as reading a book by flashlight in bed, etc. Admittedly when compared to a ceiling bounce, the diffuser does absorb a small amount of light, but the difference is more than made up for by a much more evenly distributed floody light for close distances.

  9. #9

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    Quote Originally Posted by 7histology View Post
    My L2D Premium RB100 does this flashy thing too when turning ON to the low power and I imagine from what I have heard that the L2D Premium Q5 I have just ordered will too. But this is not an issue for me - I simply could not care and anyway, I almost always use turbo.

    It will be interesting however to see if the flashy thing also occurs when I use the 1xAA body tube I have also ordered. Interesting - but of no consequence (for me anyway).
    Mine flashes with 1xAA and with 1xCR123a.

    Seems most folks don't mind. It also seems inconsistent as to which flashlights do what. Some don't flash when turned on but flash between modes, and vice-versa. Some, like mine, always flash. And some, like my other, never flash.

    I shelled out about $800 on flashlights this January, planning to sort out the wheat from the chaff. I have fairly high expectations, so little deficiencies like this bug me a lot. I have the three O-light models coming too, so if they perform smoothly, it might be bye-bye Fenix...

    This flashing business would seriously bug me until fixed if I was the electronics designer. I'd consider it a flaw, potentially even one that endangers the LED. Falls into the category of "poorly controlled step transient response." Being a conservative laboratory instrumentation designer, I still don't accept the idea of ever overdriving LEDs.
    ________
    Good day!

  10. #10
    Flashaholic*
    Join Date
    Sep 2006
    Location
    Maybe Wisconsin, maybe near Nürnberg
    Posts
    1,409

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    FWIW, none of half-a-dozen or more P3D units that passed thru my hands, Rebel or Cree anything, have had a pre-flash. The P3D obviously uses a different driver design than the P2D-type units. Somewhere I recall that the P3D driver can handle over 10 volts, ie: 3 CR123A cells with no loss of any of it's modes. By comparison the P2D head will lose low and medium with 3.7V RCR123 cells until the battery voltage runs down a bit. As an old EE, I can appreciate what the designers may have had to do with the electronics design to handle an input voltage level that seems somewhat odd for what is currently sold as a two CR123 cell device.

    FWIW, I once had my hands on a Tektronix O'scope that had an unusual power supply. The specs allowed for a mains input of _DC_ or AC to 400 hz as a mains input. I asked the Tek rep about that. He said that it was intended for the aircraft service industry that use 400 hz on-board the aircraft. I asked why such a wide-range PS was not used more. He said that it was expensive to produce, ran warm (true), and the designers were recycled into the design population at Beaverton. In the good old days, for major projects both Tektronix and HP would carry two designs thru to a bake-off. Only one design went forward. The engineers in the losing design were recycled into the pool of designers. He said that the best technical design almost never won the bake-off. The HP rep at Skokie (now Rolling Meadows) said about the same thing for HP. He said that it was pretty hard on the ego of the designers to have a technically better design, but lose the bake-off on some other factor like cost or esthetics.

  11. #11
    *Flashaholic* Gunner12's Avatar
    Join Date
    Dec 2006
    Location
    Bay Area, CA
    Posts
    10,064

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    I don't think Fenix overdrives their LEDs(Well, unless you use batteries that you aren't supposed to use).

    I think 4sevens said the flash was fixed in the newer lights.

  12. #12
    Enlightened Grateful Ned's Avatar
    Join Date
    Oct 2007
    Location
    Edmonds, WA
    Posts
    96

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    This is one of the reasons I went with a P3D recently instead of the smaller P2D which I'd hoped to belt-EDC. Looking forward to buying a P2D someday that has no flash (well, and no Cree dark crescent either, which is also annoying).

  13. #13
    Flashaholic* TORCH_BOY's Avatar
    Join Date
    Jan 2004
    Location
    Australia, Vic
    Posts
    4,243

    Default Re: Fenix L1D/P2D Rebel flashing while mode-changing?

    My Fenix L1D-L2D lights the same, even my Premium L2-D Q5 does the same

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •