ArmyTek        
Page 1 of 2 12 LastLast
Results 1 to 30 of 32

Thread: Fenix LD10 - its a new light, got problems

  1. #1
    Flashaholic
    Join Date
    Feb 2009
    Location
    Scotland
    Posts
    222

    Default Fenix LD10 - its a new light, got problems

    Just got my new Fenix LD10 disapointed that when battery supplied did not work, but thought it was probably dead battery,sinceI have now tried several batteries including rechargeables and it is a hit or a miss if it works or not, have to play around with tail cap switch to get anything to happen, have shorted out battery + - against bare part of the body, tail cap obviously off and it works, so it look like tail cap switch is the problem.

    Is there any fix for this? Don't want to return it if there is something simple I can do to rectify this fault also when it was working the light was very dim and had green tint, compared to my fenix LD0 and TK10.

  2. #2
    *Flashaholic* Marduke's Avatar
    Join Date
    Jun 2007
    Location
    Huntsville, AL
    Posts
    10,110

    Default Re: Fenix LD 10- its a new light got problems

    Tighten the retaining ring, and check continuity through the tailcap.

  3. #3
    Flashaholic* Derek Dean's Avatar
    Join Date
    Nov 2006
    Location
    Monterey, CA
    Posts
    2,394

    Default Re: Fenix LD 10- its a new light got problems

    Howdy Barrie and welcome to CPF,
    You might try taking the tailcap apart and then putting it back together. Sometimes it's simply something off kilter a bit.

    Here is a step-by-step guide for doing that:
    http://img104.imageshack.us/my.php?i...acement0vy.jpg

    Good luck.

  4. #4
    Flashaholic* powernoodle's Avatar
    Join Date
    Feb 2004
    Location
    secret underground bunker
    Posts
    2,514

    Default Re: Fenix LD10 - its a new light, got problems

    For giggles, wipe clean the contacts and threads to insure proper continuity.

  5. #5
    Flashaholic
    Join Date
    Feb 2009
    Location
    Scotland
    Posts
    222

    Default Re: Fenix LD10 - its a new light, got problems

    thanks for the suggestions cleaned contacts and threads with cleaning alcohol no improvement don't have the tweezers like tool to get tail cap out but using 2 smell screwdrivers got it to tighten a little and it is working where do i get the tool to remove the tail-cap from once again thanks Barrie

  6. #6
    Flashaholic* Nake's Avatar
    Join Date
    Oct 2006
    Location
    Cleve. OH
    Posts
    1,768

    Default Re: Fenix LD10 - its a new light, got problems

    Quote Originally Posted by Barrie View Post
    ......where do i get the tool to remove the tail-cap from once again thanks Barrie
    Small scissors or needle nose pliers will work.

    Snap ring pliers like these are also good.
    http://www.amazon.com/Heavy-Duty-Sna...338230&sr=1-37

    This place has a lot of cheap tools that will work.
    www.widgetsupply.com
    Last edited by Nake; 02-22-2009 at 03:44 PM.

  7. #7

    Default Re: Fenix LD10 - its a new light, got problems

    I've been having problems with my LD10 too. It started with flickering. Now I have flickering and worse, it only comes on if it wants to. I click the tailcap, nothing, then a few seconds later after I set it down, it comes on! It's developed a mind of it's own it seems. I really disappointed as this is the most expensive light I've bought after just getting into flashlights a couple months ago. I contacted my vendor and haven't heard anything, but it has only been two business days. I'm going to try and be patient, but I'm pretty upset.

  8. #8
    *Flashaholic* Marduke's Avatar
    Join Date
    Jun 2007
    Location
    Huntsville, AL
    Posts
    10,110

    Default Re: Fenix LD10 - its a new light, got problems

    Quote Originally Posted by zenlunatic View Post
    I've been having problems with my LD10 too. It started with flickering. Now I have flickering and worse, it only comes on if it wants to. I click the tailcap, nothing, then a few seconds later after I set it down, it comes on! It's developed a mind of it's own it seems. I really disappointed as this is the most expensive light I've bought after just getting into flashlights a couple months ago. I contacted my vendor and haven't heard anything, but it has only been two business days. I'm going to try and be patient, but I'm pretty upset.
    Have you given it the recommended maintenence?? Cleaning the contacts, tighten retaining ring, etc.

  9. #9

    Default Re: Fenix LD10 - its a new light, got problems

    All I did was alcohol swab the contacts. I'll try to do the other maintenance in a bit.

  10. #10
    Flashaholic
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    170

    Default Re: Fenix LD10 - its a new light, got problems

    I experienced the same thing only two days after receiving my LD10 from 4sevens. I attempted to tighten the retaining ring, but it was stuck and stuck. I contacted 4sevens and within two days I received an RMA and was able to send it back. Waiting on my repaired or replaced unit now, but its only been two days since I mailed it out, so it will probably be 2 more weeks In my research I didn't see any reference to this issue, so maybe it is a new defect. I was happy with the light while it worked though.

  11. #11
    Flashaholic
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    170

    Default Re: Fenix LD10 - its a new light, got problems

    Got a call from 4Sevens today. The tailswitch was faulty, they have replaced it and sent it on its way. Talk about fast service!!! I'm happy...course I'll be happier when I have it in my hands!

  12. #12
    *Flashaholic*
    Join Date
    Dec 2004
    Location
    Northern Virginia
    Posts
    5,447

    Default Re: Fenix LD10 - its a new light, got problems

    Quote Originally Posted by zenlunatic View Post
    I've been having problems with my LD10 too. It started with flickering. Now I have flickering and worse, it only comes on if it wants to. I click the tailcap, nothing, then a few seconds later after I set it down, it comes on! It's developed a mind of it's own it seems. I really disappointed as this is the most expensive light I've bought after just getting into flashlights a couple months ago. I contacted my vendor and haven't heard anything, but it has only been two business days. I'm going to try and be patient, but I'm pretty upset.
    I've exactly the same thing happen to me. It's the driver engine failure. In my case, the TC did not fix it, nor did cleaning it. It flickers in some pattern like it's sending Morse code. You will go through the disposable lites about 1 / year.

    No more Fenix, or any of its clones for me.

  13. #13

    Default Re: Fenix LD10 - its a new light, got problems

    etc, what AA replacement brand would you recommend?

  14. #14
    *Flashaholic*
    Join Date
    Dec 2004
    Location
    Northern Virginia
    Posts
    5,447

    Default Re: Fenix LD10 - its a new light, got problems

    I am waiting for EagleTac to completely debug its 2AA model... maybe upgrade the bin. The reviews look very promising, the brightest 2AA you can find, period.

    For now I am using a FiveMega 3xAA body with Surefire bezel and a Malkoff M30 module.

    I am happy, it's very well built and totally idiot proof (aside from polarity protection). One mode, on or off.

    It's not cheap, about $120? I like it.

    I also modded a Minimag 2AA with a SMJLED module. Insane runtime, "ok" brightness.

  15. #15
    Flashaholic* f22shift's Avatar
    Join Date
    Jun 2007
    Location
    Singapore, NY,SH,BJ
    Posts
    2,021

    Default Re: Fenix LD10 - its a new light, got problems

    Quote Originally Posted by zenlunatic View Post
    I click the tailcap, nothing, then a few seconds later after I set it down, it comes on! It's developed a mind of it's own it seems..

    i'm getting the same clicking on problem. randomly i click and it doesn't turn on. i twist the head, half clicks, nothing. when i click off and on, it turns on.
    cleaned what i can. the tail is sealed, it doesnt want to unscrew and i'm not going to break it.

  16. #16
    Enlightened
    Join Date
    Aug 2008
    Location
    Denmark
    Posts
    95

    Default Re: Fenix LD10 - its a new light, got problems

    Never had a problem with my LD10 in the two month I has owned it. I have it on me every day and it never failed me yet. So some of you a just pure unlucky I think

  17. #17
    Flashaholic
    Join Date
    Sep 2005
    Location
    Western TN
    Posts
    463

    Default Re: Fenix LD10 - its a new light, got problems

    I had intermittent issues the second day of ownership--discovered the cell was low. New cell, no problems. Still flickers a bit sometimes, usually right after I turn it on, but then it settles down. It's almost like the battery cannot supply enough power on the higher settings until it's warmed up. I have no flickering on low--ever.

    (Using an energizer rechargeable right now--first problem occurred on an alkaline).

    Hopefully no more issues. Flickering is weird but settles down--I really do think it's just the battery...Hope, anyway!

    prof

  18. #18

    Default Re: Fenix LD10 - its a new light, got problems

    My vendor has contacted me and said the problem cannot be reproduced on the light I sent back, after 15 minutes of troubleshooting. I pointed them to this thread. Any recommendations on troubleshooting tips to have them do before they return it as functioning correctly?

  19. #19
    Flashaholic* f22shift's Avatar
    Join Date
    Jun 2007
    Location
    Singapore, NY,SH,BJ
    Posts
    2,021

    Default Re: Fenix LD10 - its a new light, got problems

    well when it happens to me the only way to turn it on is to turn it off again and then on. so i'm thinking it's mechanically and not the driver.
    I tested with 2 separate brands of full charged 1aa nimh.

  20. #20
    Enlightened
    Join Date
    Jan 2009
    Location
    UK
    Posts
    24

    Default Re: Fenix LD10 - its a new light, got problems

    Same flickering problem for me with my 2 week old L1D.

    Last night it finally gave up completely and just came on at random, in random modes etc and with constant flickering. Changing battery and cleaning inside tailcap etc didn't make any difference. I'm sending it back tomorrow for a replacement.

  21. #21
    Flashaholic
    Join Date
    Feb 2009
    Location
    Florida
    Posts
    170

    Default Re: Fenix LD10 - its a new light, got problems

    Mine would "work" with soft click, that is, mode changes. Occasionally I would get SOS on low mode and other times irradic on/off. Try slow click and fast click to induce failure.

  22. #22
    Flashaholic* f22shift's Avatar
    Join Date
    Jun 2007
    Location
    Singapore, NY,SH,BJ
    Posts
    2,021

    Default Re: Fenix LD10 - its a new light, got problems

    So ppl don't think we are crazy..
    http://www.youtube.com/watch?v=gtIrWQsc2rg
    I was able to recreate in a couple minutes.

  23. #23

    Default Re: Fenix LD10 - its a new light, got problems

    Same experience!

  24. #24
    Flashaholic* parnass's Avatar
    Join Date
    Nov 2005
    Location
    Illinois, USA
    Posts
    2,552

    Default Re: Fenix LD10 - its a new light, got problems

    Perhaps some of your flashlights are experiencing ESD (static) problems due to the low humidity. I am getting static shocks often while walking around the house and even when putting my hand inside the pocket of some jackets and vests.

    Flashlights and other electronic devices should be engineered to tolerate normal static discharges.
    Last edited by parnass; 03-02-2009 at 07:56 PM.
    Retired engineer, author. Running Linux.

  25. #25
    Unenlightened
    Join Date
    Mar 2009
    Posts
    1

    Default Re: Fenix LD10 - its a new light, got problems

    I had the same flicker problem on all modes but the lowest. It settled when i took the battery out n put it back. But it came back. Then i remembered old trick i'v used on many of my lights that rattled. Stick a strip of copypaper folded once or twice in the chamber to keep the battery steady. Haven't had the flicker since. Hope it works with your LD10s or other lights.

  26. #26

    Default Re: Fenix LD10 - its a new light, got problems

    Got my LD10 back today. I'm still experiencing the same issues. Randomly turning off/on, flickering, not coming on. I used an Alkaline. Let that sit turned on. Put in a Ultimate Lithium (energizer) and I haven't had issues so far. Anyone else try lithium?

  27. #27
    *Flashaholic* Marduke's Avatar
    Join Date
    Jun 2007
    Location
    Huntsville, AL
    Posts
    10,110

    Default Re: Fenix LD10 - its a new light, got problems

    That would make sense if you're using alkaline. The light draws quite a bit of current in high/turbo. If the cell is low, the voltage can sag enough that the next click won't turn on because the voltage is too low for the circuit to engage.

    If that's the problem, using better cells (L91's, NiMH, etc) will solve the "issue"

  28. #28
    Enlightened
    Join Date
    Aug 2008
    Location
    Denmark
    Posts
    95

    Default Re: Fenix LD10 - its a new light, got problems

    I have tried GP alkalines with my LD10. Not a problem. Even on high. But now I use Ultimate Lithium. No problems with that either - of course.

  29. #29
    Flashaholic* f22shift's Avatar
    Join Date
    Jun 2007
    Location
    Singapore, NY,SH,BJ
    Posts
    2,021

    Default Re: Fenix LD10 - its a new light, got problems

    i had the flickering on med with a nimh. i couldnt consistently recreate it so

  30. #30

    Default Re: Fenix LD10 - its a new light, got problems

    i got the same flickering problems and after a few days it turned off, i was going to message heinnie.com about it but then i found this forum, im so glad i did.

    the tailcap was loose, i noticed for about a month now that the ridges on the bottom of the tailcap were slowly going out of alignment with the smooth sides of the torches, that should have been a clue, so i took one of my girlfriends bobby pins and used it to tighten the tailcap and hey presto its like new, popped in a charged energiser rechargable nimh battery and it works.

    thank you Derek Dean http://img104.imageshack.us/my.php?i...acement0vy.jpg this link saved me a lot of time, hassle and money.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •