Fenix Outfitters        
Results 1 to 8 of 8

Thread: Fenix FAILURE

  1. #1

    Default Fenix FAILURE

    I loved my fenix l1d/p2d (i had gotten the kit with both bodies one head and one diffuser) And I have had it for at least two years but now it has stopped working on me. I there were tell tail sign thats something was wrong like I would click it on and nothing would happen until I tapped the head on something. Now it's complete none functioning. Well just another reason to get the LD10. anything like this happen to anyone else?

  2. #2
    Flashaholic Turbo Guy's Avatar
    Join Date
    Feb 2009
    Location
    Haralson County GA USA
    Posts
    277

    Default Re: Fenix FAILURE

    Perhaps this thread may help you find the problem.

    http://www.candlepowerforums.com/vb/...d.php?t=227518T
    If you cut me do I not bleed, battery acid?

  3. #3
    Enlightened bogeymachine's Avatar
    Join Date
    Jan 2009
    Location
    wine country
    Posts
    76

    Default Re: Fenix FAILURE

    +1

    I just fixed a similar problem this morning; you probably just need a tune-up

    Quote Originally Posted by Turbo Guy View Post
    Perhaps this thread may help you find the problem.

    http://www.candlepowerforums.com/vb/...d.php?t=227518T
    fiat lux

  4. #4
    Flashaholic* Strauss's Avatar
    Join Date
    Aug 2006
    Location
    Plattsburgh, NY
    Posts
    1,301

    Default Re: Fenix FAILURE

    I actually had an LED start to "burn out" on my L2D. It still worked, but only put out about 15 lumens on turbo When turned on, you could look at the emitter and see that only a TINY portion of the phospher was lighting up. When off, you could see the area that wasn't working had turned brown like it had been cooked.

    Of course 4sevens took care of me and sent me a brand spanking new head
    EDC: Ra Clicky 100WWCn/ Muyshondt Aeon
    Other Favorites: Surefire LX2/Eagletac M2XC4/ DBS V2 1S-R2, MC-E

  5. #5
    Flashaholic* WadeF's Avatar
    Join Date
    Apr 2007
    Location
    Perkasie, PA
    Posts
    4,180

    Default Re: Fenix FAILURE

    If you got it from 4sevens (Fenix-store) they will take care of you if it isn't something you can fix. I assume you've tried cleaning the contacts and using a known good battery?
    Facebook: Wade Fulp - Follow me on Twitter! @flashlightguy and my main feed @WadeFulp Google+ PROFILE

  6. #6

    Default Re: Fenix FAILURE

    The only time my Fenix L2D quit working was because the retaining-ring for the spring in the tailcap got loose. You can tighten this ring with small needle nose pliers or with a couple of nails. Now, you did mention that you had both the L1D and P2D bodies, so the tailcap might not be the issue. Good luck.

  7. #7
    *Flashaholic* Marduke's Avatar
    Join Date
    Jun 2007
    Location
    Huntsville, AL
    Posts
    10,110

    Default Re: Fenix FAILURE

    Alcohol swab all contacts on the head and both bodies. Tighten tailcap retaining rings. Come back and let us know if that did it (it usually does).

  8. #8
    Banned
    Join Date
    Dec 2007
    Location
    Perth, Western Australia
    Posts
    526

    Default Re: Fenix FAILURE

    Now this is an interesting one. Assume if it's the LED globe and manufactueres claim 50,000 or 100,000 hrs will they replace it with a new one without asking any questions.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •