Angryfox        
Results 1 to 10 of 10

Thread: Stainless steel LD01 won't turn on

  1. #1
    Flashaholic
    Join Date
    Oct 2005
    Location
    Malaysia
    Posts
    102

    Sigh Stainless steel LD01 won't turn on

    I purchased the limited edition Stainless Steel LD01 from 4Sevens last December. It's a lovely flashlight and I've been carrying it on my keyring. I don't use it often, but recently I've been using it a bit more. After working well for several months, it suddenly would not switch on. I tried changing the battery and cleaning the contact area but it didn't help.

    After many tries, it sometimes turns on but flickers a lot and sometimes cycles through modes. Often it will turn on for a short while, then turn off. Strangely it will sometimes activate when it is tightened not quite all the way, just before it becomes tight but when it's tight all the way, it turns off.

    Just wondering if anyone else has had this issue and has any suggestions before I pursue warranty claims (I live in Malaysia, so it's a tad inconvenient )

    Thanks!

  2. #2
    *Flashaholic* Patriot's Avatar
    Join Date
    Feb 2007
    Location
    Arizona
    Posts
    10,663

    Default Re: Stainless steel LD01 won't turn on

    Another thing you can try. Unscrew the head and remove the battery. Take the battery tube and using some 400-600 grit sand paper resting on a flat surface, twist the body several times face down on the paper. You just want to clean and true the battery tube face so don't overdo it. Clean the face with a clean dry towel, re-lube and reassemble. This may fix or improve the problem you're having.

  3. #3
    Flashaholic* WadeF's Avatar
    Join Date
    Apr 2007
    Location
    Perkasie, PA
    Posts
    4,180

    Default Re: Stainless steel LD01 won't turn on

    Do you have a battery tester to know that you're putting in a good battery? Maybe try some other new batteries first.
    Facebook: Wade Fulp - Follow me on Twitter! @flashlightguy and my main feed @WadeFulp Google+ PROFILE

  4. #4
    Flashaholic* gswitter's Avatar
    Join Date
    Apr 2006
    Location
    California
    Posts
    2,586

    Default Re: Stainless steel LD01 won't turn on

    If you tighten it all the way, and it doesn't turn on, does the head get warm?

    Since it occasionally come on when it's not tightened all the way, it sounds like driver is board is loose, and among other things, is sometimes causing the negative contact ring to come in contact with the inside of the head.



  5. #5
    Flashaholic*
    Join Date
    Aug 2003
    Location
    houston, tx
    Posts
    2,291

    Default Re: Stainless steel LD01 won't turn on

    Get a paper clip, bent the tip and hook the spring out of the battery tube, get the green thing that you wash the dish with, tear a small piece and use a chop stick and clean the inside of the battery tube, dry it, put the spring back in.
    See if it work.

  6. #6
    Flashaholic* EngrPaul's Avatar
    Join Date
    Sep 2006
    Location
    PA
    Posts
    3,679

    Default Re: Stainless steel LD01 won't turn on

    Typically I would start in the battery tube.

    I remove the spring and put it in isopropyl alcohol. Then I clean the bottom of my battery tube with the same

    Then I put a drop of deoxit gold in the bottom of the tube. Then I remove the excess with a q-tip. Push in the spring, and go over it with the q-tip still wet from deoxit.

    If you have strong crud in the bottom of your tube, you could be more aggressive, I've never had to.

    Deoxit gold also makes a great lubricant for the threads. Clean all the old goop out, a round wooden toothpick works great to pull debris out of the threads

  7. #7
    Unenlightened Lake Effect's Avatar
    Join Date
    Nov 2008
    Location
    Mannsville, NY
    Posts
    11

    Default Re: Stainless steel LD01 won't turn on

    Sounds exactly like what mine does when the battery gets low. Hard to believe there would be that much crud in battery tube. I carry mine in my pocket every day at work and I don't see any junk in my battery tube?
    fiat lux

  8. #8
    Retired Administrator Norm's Avatar
    Join Date
    Jun 2006
    Location
    Australia
    Posts
    9,515

    Default Re: Stainless steel LD01 won't turn on

    Quote Originally Posted by jc28841 View Post
    I purchased the limited edition Stainless Steel LD01 from 4Sevens last December.
    Four Sevens warranty is excellent.
    Norm

  9. #9
    Flashaholic* Braddah_Bill's Avatar
    Join Date
    Oct 2004
    Location
    Hawaii
    Posts
    586

    Default Re: Stainless steel LD01 won't turn on

    A agree with checking out the bottom of the tube.

    I had a friend take a look at the one I gave him (not SS) cause it wasn't working. The first I did was put his head on mine and it worked fine so I knew it wasn't the head. I then pulled the spring, cleaned it and the bottom of the tube. When I put back together it worked fine.

  10. #10
    Flashaholic
    Join Date
    Oct 2005
    Location
    Malaysia
    Posts
    102

    Default Re: Stainless steel LD01 won't turn on

    Thanks for all the great tips guys

    I tried removing the spring and there's only a little bit of dirt at the bottom... I cleaned it out as best i could with a q-tip.

    It works somewhat better now... much easier to activate it although there's still the odd flicker. I think I'll need to do some better cleaning and maybe buy some of that deoxit gold.

    Thank you all again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •