NEXTORCH - 300 m long-shot E6        
Results 1 to 11 of 11

Thread: My Jetbeam is BROKE - any ideas???

  1. #1

    Default My Jetbeam is BROKE - any ideas???

    Hi all,

    Well, I went to turn on my Jet III Pro ST today and it is out of commission.

    The light will turn on, but immediately dims, strobes a bit, then just sits there on a very low setting.

    When I try to access the programming, it starts low, works up to medium, flashes like it should, then ramps back down to very dim, strobes, and shuts off.

    I have tried 3 batteries (18650's) that work fine in other lights.

    Any ideas what it could be?

    Also, I bought the light used from a member here but have the box. Any chance Jetbeam will repair it?

    thanks,

    --Duck911

  2. #2
    Flashaholic*
    Join Date
    Aug 2003
    Location
    houston, tx
    Posts
    2,291

    Default Re: My Jetbeam is BROKE - any ideas???

    Try a paper clip for a tail cap.

  3. #3

    Default Re: My Jetbeam is BROKE - any ideas???

    Not really entirely sure what you mean, but I removed the tailcap, and put a car key across the top of the battery to the flashlight body. The light flashes sort of bright for a very brief moment, then scales down, flashing a little, to almost nothing.

    --Duck911

  4. #4
    Flashaholic maskman's Avatar
    Join Date
    Jul 2009
    Location
    OK
    Posts
    190

    Default Re: My Jetbeam is BROKE - any ideas???

    Here's a link to a trouble shooting guide.
    http://www.candlepowerforums.com/vb/...d.php?t=227518

  5. #5

    Default Re: My Jetbeam is BROKE - any ideas???

    Quote Originally Posted by duck911 View Post
    Not really entirely sure what you mean, but I removed the tailcap, and put a car key across the top of the battery to the flashlight body. The light flashes sort of bright for a very brief moment, then scales down, flashing a little, to almost nothing.

    --Duck911

    That is just a simple way of seeing if the switch is the problem. You did the test with your keys, and your light did the same thing, so you can rule your switch out of the equation. I am not an expert at light repair, but I would guess the problem is with the circuit board (driver?) that the LED is connected to.

  6. #6
    Flashaholic* berry580's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia
    Posts
    1,138

    Default Re: My Jetbeam is BROKE - any ideas???

    if all else fails, i have confidence Jetbeam will fix it. they have pretty good customer service from experience.
    Maglite 4D Incad., Solitaire, 3D LED Jetbeam Jet-I MKII R, Jet-III PRO Ti, Jet-Ti M, TC-R3 ,TC-10 Fenix LD01 SS Surefire C2 4Sevens Quark AA Ti, Quark Mini AA, Preon 0

  7. #7
    Flashaholic
    Join Date
    Sep 2007
    Location
    Texas, Out yonder Way.
    Posts
    135

    Default Re: My Jetbeam is BROKE - any ideas???

    remove the forward section from the body clean the very end that makes contact with the pill. Also, clean the brass contact ring, and the threads on both ends. can't hurt.
    Last edited by texbaz; 11-29-2009 at 12:37 AM. Reason: Wrong Batteries recomended

  8. #8
    Flashaholic* berry580's Avatar
    Join Date
    Oct 2008
    Location
    Sydney, Australia
    Posts
    1,138

    Default Re: My Jetbeam is BROKE - any ideas???

    Jet-III ST only takes 18650/17670s (4.2V max). No primaries that i know of at least.
    Maglite 4D Incad., Solitaire, 3D LED Jetbeam Jet-I MKII R, Jet-III PRO Ti, Jet-Ti M, TC-R3 ,TC-10 Fenix LD01 SS Surefire C2 4Sevens Quark AA Ti, Quark Mini AA, Preon 0

  9. #9
    Flashaholic
    Join Date
    Sep 2007
    Location
    Texas, Out yonder Way.
    Posts
    135

    Default Re: My Jetbeam is BROKE - any ideas???

    Quote Originally Posted by berry580 View Post
    Jet-III ST only takes 18650/17670s (4.2V max). No primaries that i know of at least.
    Berry580, you are correct looks like it is a Jet-III ST not a BVC good catch.

  10. #10
    Flashaholic henry1960's Avatar
    Join Date
    Feb 2009
    Location
    Bristol, Ct.
    Posts
    375

    Default Re: My Jetbeam is BROKE - any ideas???

    Quote Originally Posted by mikekoz View Post
    , but I would guess the problem is with the circuit board (driver?) that the LED is connected to.

    I think your absolutely right. I had the same promblem with a different light and that was the promblem.

  11. #11
    Flashaholic
    Join Date
    Sep 2007
    Location
    Texas, Out yonder Way.
    Posts
    135

    Default Re: My Jetbeam is BROKE - any ideas???

    Have you measured the voltage of the 3 different batteries? Just curious as to what you cmae up with.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •