FourSevens        
Results 1 to 26 of 26

Thread: My Zebralight is trippin'

  1. #1

    Default My Zebralight is trippin'

    I lent my SC51w to my wife this morning for her pre-dawn walk... When I got it back it is constantly cycling low-med-high... And its stuck on, only unscrewing the batt cap breaks the cycle.. I emailed ZL but they havent replied... Anyone seen this? Did she unclock some hidden mode or something, and if so how do you disable it? Thanks,

  2. #2
    Flashaholic DIΩDΣ's Avatar
    Join Date
    Aug 2011
    Location
    Ohio
    Posts
    262

    Default Re: My Zebralight is trippin'

    Does it still feel like the button is clicking on or off? Sounds like the button is jammed on.

  3. #3

    Default Re: My Zebralight is trippin'

    Did she drop it?

  4. #4

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by DIΩDΣ View Post
    Does it still feel like the button is clicking on or off? Sounds like the button is jammed on.
    Yes, it does act as if the button is jammed on now that you mention it. But it is not, it clicks when you click it (although nothing happens).

  5. #5

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by al g blenny View Post
    Did she drop it?
    I havent gotten a chance to ask her yet, we havent crossed paths yet today. But it does not have any drop marks...

  6. #6
    Flashaholic
    Join Date
    Aug 2011
    Location
    NC
    Posts
    206

    Default Re: My Zebralight is trippin'

    My ZL SC51w that I just got has been acting kind of squirrely ,how old is yours?

  7. #7
    Flashaholic
    Join Date
    Jul 2005
    Location
    Australia
    Posts
    251

    Default Re: My Zebralight is trippin'

    I think others with water ingress have had that problem. Any fog in the lens? Maybe take the battery out and stick some silica gel in it the battery compartment, close it up and put it somewhere warm for a bit.

  8. #8
    Flashaholic* 880arm's Avatar
    Join Date
    Aug 2011
    Location
    Wildlands of Western Kentucky
    Posts
    1,752

    Default Re: My Zebralight is trippin'

    I've had the same issue with my Spark SL6. No drops and no water.

    In my case I found that if I had the head or tail too tight it would do this. Try loosening one or other other (very slightly) and see if it helps.

  9. #9

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Scubie67 View Post
    My ZL SC51w that I just got has been acting kind of squirrely ,how old is yours?
    Mines not old at all, a few months...

  10. #10

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Foxx510 View Post
    I think others with water ingress have had that problem. Any fog in the lens? Maybe take the battery out and stick some silica gel in it the battery compartment, close it up and put it somewhere warm for a bit.
    We are in the desert in a drought, so I don't have to concern myself with water ingress ..

  11. #11

    Default Re: My Zebralight is trippin'

    My wife didn't drop it, she just said it "wouldnt turn off"...

  12. #12
    Flashaholic
    Join Date
    Aug 2011
    Location
    NC
    Posts
    206

    Default Re: My Zebralight is trippin'

    If you read the post I made,tre offered the suggestion of cleaning the threads and contacts you could try that.Sometimes digital electronics will reset themselves when power is interrupted which is also what I had tried,so far mine is working after I pulled the battery out for awhile.Don't know if the ZL's are like that though,no one has answered yet on that...I guess you could try it though,it can't hurt none.

    http://www.candlepowerforums.com/vb/...rking-properly

  13. #13

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Scubie67 View Post
    If you read the post I made,tre offered the suggestion of cleaning the threads and contacts you could try that.Sometimes digital electronics will reset themselves when power is interrupted which is also what I had tried,so far mine is working after I pulled the battery out for awhile.Don't know if the ZL's are like that though,no one has answered yet on that...I guess you could try it though,it can't hurt none.

    http://www.candlepowerforums.com/vb/...rking-properly
    Thanks. I let it sit a couple hours without battery, also tried cleaning all the contacts/threads, no luck... Thanks again,

  14. #14
    Flashaholic
    Join Date
    Aug 2011
    Location
    NC
    Posts
    206

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Chrisdm View Post
    Thanks. I let it sit a couple hours without battery, also tried cleaning all the contacts/threads, no luck... Thanks again,
    Ahh.Maybe it is a stuck switch as suggested.I just got mine today and this my first ZL.I think it's a great light ,but I hope there isn't some QC issues going on with the new(ish) ones that are coming down the pipe.I would try everything I think I could before RMA though,I hate waiting on stuff myself.

  15. #15

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Scubie67 View Post
    Ahh.Maybe it is a stuck switch as suggested.I just got mine today and this my first ZL.I think it's a great light ,but I hope there isn't some QC issues going on with the new(ish) ones that are coming down the pipe.I would try everything I think I could before RMA though,I hate waiting on stuff myself.
    Just got my RMA number from Zebralight, off to the post office... Bummer. But I'm glad at least they are standing behind it.

  16. #16
    Flashaholic
    Join Date
    Aug 2011
    Location
    NC
    Posts
    206

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Chrisdm View Post
    Just got my RMA number from Zebralight, off to the post office... Bummer. But I'm glad at least they are standing behind it.
    Glad to hear they are making it right

  17. #17
    Flashaholic* Samy's Avatar
    Join Date
    May 2011
    Location
    Australia
    Posts
    540

    Default Re: My Zebralight is trippin'

    When i undo the tailcap (lockout) on my SC51, then press the button and screw the tailcap back tight mine flashes - it's only .2 lumen or so... but it does. Does anyone else's do this? No big deal, just something i noticed...

    cheers

  18. #18
    Flashaholic* Lite_me's Avatar
    Join Date
    Jun 2006
    Location
    Northern OH
    Posts
    1,992

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Samy View Post
    When i undo the tailcap (lockout) on my SC51, then press the button and screw the tailcap back tight mine flashes - it's only .2 lumen or so... but it does. Does anyone else's do this? No big deal, just something i noticed...

    cheers
    Yes, mine does that also. When you press the switch with the battery disconnected, it depletes the energy stored in the light engine. Reconnecting the battery energizes the electronics and causes the flash.
    "People don't plan to fail, they fail to plan."

  19. #19
    Flashaholic
    Join Date
    Aug 2011
    Location
    NC
    Posts
    206

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Samy View Post
    When i undo the tailcap (lockout) on my SC51, then press the button and screw the tailcap back tight mine flashes - it's only .2 lumen or so... but it does. Does anyone else's do this? No big deal, just something i noticed...

    cheers
    Yep...sure does, mine is the SC51w and does that to.Thats why when I was having problems with it I didn't know what to think.The flash is only a 1/3 of a second or so and maybe a lumen (the L1 setting maybe)

  20. #20
    Flashaholic
    Join Date
    Aug 2011
    Location
    NC
    Posts
    206

    Default Re: My Zebralight is trippin'

    Quote Originally Posted by Lite_me View Post
    Yes, mine does that also. When you press the switch with the battery disconnected, it depletes the energy stored in the light engine. Reconnecting the battery energizes the electronics and causes the flash.
    Ahh ok ...so thats it,was wondering about that to

  21. #21
    Unenlightened
    Join Date
    Feb 2010
    Location
    PA
    Posts
    12

    Default Re: My Zebralight is trippin'

    I got an SC60w direct from Zebralight about a week ago. The button was very "squirrely" would click on by just moving my finger close to it. Once it went into "Poltergeist" mode where it came on high all by itself while tail-standing on my desk!

    I actually got an RMA to return it, but then I read here about cleaning the threads and contacts. There was a lot of silicone lube from the factory on the O-ring and threads. I cleaned it up and it has been much better. I have decided it does not need to go back.

    If Zebralight could keep the 18650 form factor and make it even smaller for pocket carry and use the new switch like on the SC600 and perhaps put some kind of tiny capacitor on the board to prevent/absorb electrical noise that switches the light on randomly, I would be first in line.

    Zebra makes a good light and their UI is my favorite. I would like them to just get it PERFECT.

  22. #22
    Unenlightened
    Join Date
    Feb 2010
    Location
    PA
    Posts
    12

    Default Re: My Zebralight is trippin'

    I wanted to post this update:

    Last night I pulled the Tenergy 18650 battery out of my SC60w to recharge. I replaced it with an EagleTac 18650, which is just a teeny-tiny bit shorter than the Tenergy.

    I started having full-on "Poltergeist mode" again. The light was coming on just by being put in my pocket. It was coming on high just by being touched near the button (not actually touching the button).

    I took the tailcap, which I though was already on tight, and turned it hard as I could with my finger and felt it tighten down a teeny-tiny bit. Maybe 1/16th of a turn? I mean I could feel it get just ever so slightly more tight.

    The problem went away.

    I do love the Zebra's but the electronic switch can have a mind of it's own if everything isn't TIGHT and RIGHT.

    Zebralight, I hope you are taking note. You *almost* have the perfect family of lights. Justa little more R&D and you will be there!

  23. #23

    Default Re: My Zebralight is trippin'

    Update: Zebralight still has mine, says repair will take another couple weeks, even though theyve had it for over a month now... They must be waiting on parts or something, or backed up with repairs... The latter possibility doesn't sit well.. :{

  24. #24
    Flashaholic* burntoshine's Avatar
    Join Date
    Dec 2008
    Location
    the local group
    Posts
    957

    Default Re: My Zebralight is trippin'

    over a month? that's quite a bit of time. that doesn't seem right. it doesn't sound like they're taking care of their customers.

    i really like their lights. i own 2 and may have given them a sale on the sc600; just recommended it to a friend who seems excited about it. is this normal for customer service with zebralight??
    If it wasn't for disappointment, I wouldn't have any appointments.

  25. #25
    Flashaholic* tre's Avatar
    Join Date
    May 2010
    Location
    Northern IL USA
    Posts
    1,222

    Default Re: My Zebralight is trippin'

    The problem is shipping to China and back. I believe they are opening a manufacturing plant and repair shop in the US in the very near future so hopefully that should help.

  26. #26

    Default Re: My Zebralight is trippin'

    Got it back today, back to normal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •