The Fenix-Store        
Results 1 to 9 of 9

Thread: Klarus intermitant LED issue?

  1. #1

    Default Klarus intermitant LED issue?

    Hey everybody, new guy here to seek some advice about an issue I just started having. Two years ago I bought a Klarus XT2C like the one in this link

    http://www.klaruslight.com/index.php...tid=128&id=115

    I've hardly used it and never abused it, and it's worked great for two years now, however after taking it apart to charge the battery recently, I have an issue now. I know the batteries are good as I use them in another Klarus flashlight with no problems. The issue I am having is the LED light will only come on when I just lightly start to screw the centre body portion to the LED front end. The flashlight body is 3 pieces, the rear portion with the on/off switches, the centre portion which is just a tube the battery sits in, and the front end which holds the bulb.

    When I screw flashlight together I can't get the light to come on no way no how, shaking twisting the ends tighter looser, etc. However when I unscrew the LED front end to about the last thread until it falls apart I can get the light to come on. But even then it's tricky as the light will flicker like it has a poor connection (which it does as it's the last thread holding it together). If you get it in just the right spot and hold it that way you can get the LED to stay on, so I'm sure the battery and bulb is good. But once you start to screw it together the LED goes out and will not come back on until I unscrew it again.

    FWIW, the entire flashlight is very clean inside and out, never been submerged in water or other liquids. Looking at it, it still looks brand new, and the O-rings that keep it water tight are in the correct places, appear fine, and are the original O-rings.

    So I figure I must have a bad connection with the battery, but can't figure out why as nothing has changed. I have two different rechargeable batteries and both have worked fine for the 2 years now. Has anybody else had a similar issue and how did you resolve it? Thanks

  2. #2

    Default Re: Klarus intermitant LED issue?

    It seems the LED part is OK, maybe electric conduction has problem.
    You can try to tighten the Switch Retaining Ring, see if it effective.

  3. #3
    Flashaholic*
    Join Date
    Jan 2009
    Location
    UK
    Posts
    1,075

    Default Re: Klarus intermitant LED issue?

    Clean all electric connections and threads, tighten up switch retaining ring. Hopefully should be fine.

  4. #4

    Default Re: Klarus intermitant LED issue?

    Quote Originally Posted by zs&tas View Post
    Clean all electric connections and threads, tighten up switch retaining ring. Hopefully should be fine.
    Yep. that was it. To be honest everything looked good and clean and I even stuck the corner of a rag in there to see if it was dirty and it didn't appear to be. What I then did was buy some rubbing alcohol and clean it all good with Q-tips. I noticed the Q-tips were turning black so I used a couple of them and got it good. I then put it back together and it works like new again. Lesson learned is even though it looks clean it may not be. I then did the same thing to my two year old Klarus XT 11 which also looked clean and sure enough the Q-tips turned back.

    I'll try and remember to clean them once a year as maintenance.


    Thanks.

  5. #5
    Flashaholic*
    Join Date
    Jan 2009
    Location
    UK
    Posts
    1,075

    Default Re: Klarus intermitant LED issue?

    Glad it worked out, you did absolutely the right thing. Its quite a common thing really. Did u put a little lube on the o rings to keep them moist and your flashlight water tight ?

  6. #6

    Default Re: Klarus intermitant LED issue?

    Ha! Timely thread. I own a KLARUS ST-20 (2XAA-no longer in production if memory serves) and I have used this light sparingly thus, this Flashlight is in very nice physically condition
    (I keep it in it's holster). At any rate, I tried cycling through the modes the other night and it wasn't working properly. I.E. there was very little (in any) difference in light's lumens at different modes.
    At first, I thought this might be due to the batteries go weak. So, even replacing with new batteries, the problem continued. So, I took the unit apart and (on general principle) I did the exact same procedure that UNCOILER (as suggested by ZS&TAS) did and BINGO! The KLARUS ST-20 works like new! I suspect the "grease" on the Head (or Tail cap) threads eventually makes it way onto the contact points and this is the root of the problem. Yep......regular maintenance is a good thing!

    SixCats!

  7. #7

    Default Re: Klarus intermitant LED issue?

    Quote Originally Posted by zs&tas View Post
    Glad it worked out, you did absolutely the right thing. Its quite a common thing really. Did u put a little lube on the o rings to keep them moist and your flashlight water tight ?
    I didn't grease the O-rings yet as I was unsure what I should or shouldn't use. I have all kinds of lubricants in my shop, is there a type you would recommend?

  8. #8
    Flashaholic* vadimax's Avatar
    Join Date
    Dec 2015
    Location
    Vilnius, Lithuania
    Posts
    2,064

    Default Re: Klarus intermitant LED issue?

    Quote Originally Posted by Uncoiler View Post
    I didn't grease the O-rings yet as I was unsure what I should or shouldn't use. I have all kinds of lubricants in my shop, is there a type you would recommend?
    In lights we use not lubricants, but sealants And they are silicone based:


  9. #9

    Default Re: Klarus intermitant LED issue?

    I got silicone grease, thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •