The Fenix-Store        
Results 1 to 8 of 8

Thread: Zebralight SC600 Mk II L2 Issues and Help appreciated

  1. #1

    Default Zebralight SC600 Mk II L2 Issues and Help appreciated

    Hello first time poster here. I am having some problems with my light that I hope someone can help me with. I've had this light for about 3 years now and use it as a bike light. It has been a great light for my needs. I started noticing issues with it today. I will put a charged battery in it and it will immediately go dim. When I test the battery with the light, it only flashes once indicating it thinks it is low on battery.

    I have 5 different 18650 batteries and have used them all before without issue. Only 1 of them will work my flashlight correctly at the moment - a 2900 mAh protected battery. The other 4 are not protected and are not working in my light at the moment. These all used to work in my light.

    I have a 2nd Zebralight headlamp and I tested all of the batteries in it and they all work fine.

    Any ideas on what I should do at the moment? Thank you for your help!

  2. #2
    Moderator
    archimedes's Avatar
    Join Date
    Mar 2011
    Location
    CONUS, top left
    Posts
    10,572

    Default Re: Zebralight SC600 Mk II L2 Issues and Help appreciated

    Hello and welcome to CPF

    Your post above has been approved, but the thread was moved to LED Flashlight forum
    ... is the archimedes peak

  3. #3
    Flashaholic* CelticCross74's Avatar
    Join Date
    Aug 2014
    Location
    Fairfax Va
    Posts
    3,860

    Default Re: Zebralight SC600 Mk II L2 Issues and Help appreciated

    Hmm interesting OP. I am sure more will chime in here but I am going to go with those 3 18650's have just lost enough of their capacity and amperage capaibilty as to where they just will not work in the SC600 MkII. I would honestly get some fresh 3500mah NCR18650GA 10amp cells. I am trying to remember here, the MkII is that the one that will ONLY fit an unprotected flat top or no? I have the light and cannot find it right now amidst my piles of other lights. I think it is the MkIII that only fits the flat top. Hmm. But yes that is what I am going with. Just get some fresh cells.

  4. #4

    Default Re: Zebralight SC600 Mk II L2 Issues and Help appreciated

    I would try cleaning the contacts inside. Detoxit is best, but rubbing alcohol will work.
    The best weapon in the world is a flashlight. . . . Why? . . . So you can look deep into the other guy's eyes.

  5. #5

    Default Re: Zebralight SC600 Mk II L2 Issues and Help appreciated

    Quote Originally Posted by CelticCross74 View Post
    Hmm interesting OP. I am sure more will chime in here but I am going to go with those 3 18650's have just lost enough of their capacity and amperage capaibilty as to where they just will not work in the SC600 MkII. I would honestly get some fresh 3500mah NCR18650GA 10amp cells. I am trying to remember here, the MkII is that the one that will ONLY fit an unprotected flat top or no? I have the light and cannot find it right now amidst my piles of other lights. I think it is the MkIII that only fits the flat top. Hmm. But yes that is what I am going with. Just get some fresh cells.
    It can fit flat top or unprotected. Since the protected one is working, I ordered a couple NCR18650GA protected batteries to see if they will work. The weird thing is they all work fine in my Zebralight H600 headlamp. Could it be a dirty contact issue? The longer protected battery is making better contact? I was planning on trying some deoxit next.

  6. #6
    Flashaholic*
    Join Date
    Jun 2014
    Location
    Canada
    Posts
    2,651

    Default Re: Zebralight SC600 Mk II L2 Issues and Help appreciated

    Quote Originally Posted by pharmd View Post
    It can fit flat top or unprotected. Since the protected one is working, I ordered a couple NCR18650GA protected batteries to see if they will work. The weird thing is they all work fine in my Zebralight H600 headlamp. Could it be a dirty contact issue? The longer protected battery is making better contact? I was planning on trying some deoxit next.
    Sounds like a dirty contact issue, or maybe the springs have become compressed and are not making good contact with shorter cells. You could try stretching the springs, that has helped on some of my lights.

    The Zebralight should still get medium modes just fine, even with crap batteries. But the fact it's giving just 1 flash, indicates it thinks the battery has a low voltage (below 3.5v). And if it's immediately dropping to low, then that sounds like the low-voltage step-down sequence kicking in, which doesn't happen until the battery is down to about 2.8v or 2.9v (under load).

    Measure the voltage of those batteries with a multi-meter, and see what it says. If it's not getting close to 4.2v after a full charge, then there's something wrong with either the batteries or the charger. If you can measure the voltage under some load, that would be an even better test of the batteries.

  7. #7
    Flashaholic* CelticCross74's Avatar
    Join Date
    Aug 2014
    Location
    Fairfax Va
    Posts
    3,860

    Default Re: Zebralight SC600 Mk II L2 Issues and Help appreciated

    OP I also agree with what others have posted here about cleaning up the light with DeOxit Red(preferable) or rubbing alcohol. It is your BIKE LIGHT right? A bike light would 100% get dirty easy. I have even gone as far as to DeOxit all the contact points in some of my lights AND clean the postive and negative ends of my cells. So, clean it up, fresh cells. If it is not good to go after that contact ZL for further instruction

  8. #8

    Default Re: Zebralight SC600 Mk II L2 Issues and Help appreciated

    Thanks for the help everyone! I got some deoxit at guitar center and cleaned the contacts and batteries. It took a few tries to get it working again. After the first couple of sprays I put a flat top battery in and it would work about half the time. Tapping the flashlight would get it working normally again. Did one more final clean and let it dry overnight and everything looks normal.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •