HDS Systems        
Results 1 to 10 of 10

Thread: QK2A MKIII Trouble

  1. #1

    Default QK2A MKIII Trouble

    So my brand new mkiii 2aa quark arrived today. Iím sad to say I already have email communication with customer service. UI acting funny occasionally switching from max to low... loose driver board... and this is just opinion but it seems way less than 500 lumens. Hope I just got a fluke but we will see. Havenít even decided on trying to return it as I see absolutely no reason the customer should ha e to pay for shipping on a defective product.

  2. #2

    Default Re: QK2A MKIII Trouble

    High mode is 300 lumens, not 500.
    500 lumens requires a rapid double press.
    Did you charge the batteries before using the light? When the batteries get low, the light switches out of high mode.

  3. #3

    Default Re: QK2A MKIII Trouble

    Have you tried recharging the batteries or using fresh batteries? My Q2A did the same thing until I recharged the batteries.

  4. #4

    Default Re: QK2A MKIII Trouble

    I never use any rechargeable battery without charging it first. This includes ďprechargedĒ cells.

  5. #5

    Default Re: QK2A MKIII Trouble

    Hmmm, well I appreciate the suggestions but yes I did ensure charged batteries. Additionally if you notice my use of the wording ďmaxĒ not high. Which is why I noted 500lm.

    In any case Iíll update after customer service has the opportunity to address my issues.

  6. #6

    Default Re: QK2A MKIII Trouble

    Ever resolve this? Same issue with mine, which I received today.

  7. #7
    Join Date
    May 2020

    Default Re: QK2A MKIII Trouble

    I had a similar issue with my Preon P2 Mkiii when I got it, and the problem turned out to be the Recyko batteries that were included. Granted, that's AAA, not AA, but if you're using those, try switching them out to something better like Eneloop. That worked for me at least, and I get more time in high mode. But the Nichia LED still doesn't look quite as bright as I'd hoped so it became my indoor light. May not be super bright but I'm in love with the color of it! I'm looking at getting a Quark MKiii also, but I need something bright, so you may have just swayed me.

  8. #8

    Default Re: QK2A MKIII Trouble

    Quote Originally Posted by JimIslander View Post
    Ever resolve this? Same issue with mine, which I received today.

    Yes and no. Eventually Jason must have got wind and offered to have me send the light in. I never did as after disassembling the head and reassembling it (just unscrewing, no electrical work) and "pushing" the driver board with my finger its been working perfectly. Not sure what the problem was originally. Still, I was very disappointed in the customer service but I am now very happy with the light!

  9. #9

    Default Re: QK2A MKIII Trouble

    This is what mine is doing (as tested with the standard body PLUS the CR123 and single AA adapter tubes):

    1. Batteries that came with it work fine. All rechargeables work fine.
    2. Single Tenergy CR123A primary (3.1 volts brand new), flashes bright and then immediately goes to dim
    3. Single Lithium, Energizer AA primary (1.81 volts new), flashes bright and then immediately goes to dim
    4. Two Lithium, Energizer AA primary (3.62 volts), flashes bright and then immediately goes to dim

    Software low voltage is 0.9 volts for one cell and 1.8 volts for two cells. This explains why one Li AA doesn't work. A new Li AA measures 1.8 volts, so the light thinks it has two AA cells in it that have dropped below the 1.8 volt threshold.

    But why don't the CR123A and 2xAAs work? One CR123A is 3.1 volts, which is above the 1.8 cutoff. 2 AAs is 3.62 volts, also well above the 1.8 volt cutoff. My guess is that the high cutoff is right at 3 volts. I did review the website specs and it does say voltage range 0.9 - 3.0 volts, which covers rechargeables and alkalines. But the three replies I received from tech support only mentioned low voltage cutoff, so I am only guessing. I also have no idea what the single cell voltage range is, since 0.9 is low, but 1.8 is low cutoff for two cells. Must be something like 0.9 - 1.5 volts, since the light is rated for Alkalines.

    I guess it boils down to user error. Light isn't designed to work with Li primaries.

    Interestingly, all the other modes except high work just fine with Li primaries.
    Last edited by JimIslander; 06-02-2020 at 01:59 PM.

  10. #10

    Default Re: QK2A MKIII Trouble

    Interesting. Havenít tried mine with L91s. Guess Iíll do that eventually.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts