I bought a Fenix RC09 several years back. It has actually been a great light most of the time. I typically use it as a cap light. Recently, after charging it in an external battery charger, I inserted the battery in the light and off I went on a horseback ride. When it was dark enough to need it, I turned the switch on and the light illuminated for less than a second and stopped. In the past, when that has happened, I would simply remove the battery, re-insert and it work generally work. Last night, I tried that several times and I could not get it to work.

When I returned home, I put the battery on the charger, again. The charger indicated that the battery was fully charged. So, I placed it back in the Fenix RC09 and it worked again. Anyway, for those of you that know flashlights and batteries much better than I do (and that IS most of you reading this) what it is the likely source of the problem? And, perhaps more importantly, what should I do to correct it? Essentially, I am thinking of simply trying another 16340 battery. I have an Acebeam TK16 on order as well as an additional, spare 16340 battery.

This happened again last night, too. Does it sound like the problem is the battery or the light itself? I can't wait to get another 16340 battery to try in the light.