Imalent        
Results 1 to 3 of 3

Thread: DX80 runtime issue

  1. #1

    Default DX80 runtime issue

    Hi all,

    I have a DX80 that was purchased in May 2019. It literally has been used 10 times, never exposed to the elements. The run time is really bad. Here's what's happening:

    1. I charge the light and it appears to go through the process normally.
    2. triple click shows 15.8V.
    3. I turn on the light even to the lowest setting (120Lm) for just 20 seconds, triple click shows 15V and the battery indicator is down to 60%.
    4. The run-time on 2nd or 3rd lowest Lumen setting may only be 10 minutes... really bad.


    I emailed Imalent and got a reply in broken English, they seem to indicate that I should run the light in Turbo (32000 Lm) as "long as I can" and then turn it off and repeat this 3 times. Do they mean run the light until the thermal error appears or the battery runs down and then recharge it or just wait a bit for the battery to recovery and try again? What's the science behind this?

    Then they asked me for the serial# of the light... I cannot find anything like a serial # or a Series number starting w/ IM--- anywhere on the light or the battery pack. Where is this found?


    I should have bought a light that uses regular 18650 batteries instead of this expensive battery pack...

  2. #2

    Default Re: DX80 runtime issue

    The DX80 product serial number is on the box
    How did you contact our official website and on which platform did you buy
    I will follow up the question for you
    My email:imalentlight@gmail.com

    https://www.imalentstore.com/

  3. #3

    Default Re: DX80 runtime issue

    Quote Originally Posted by imalent View Post
    The DX80 product serial number is on the box
    How did you contact our official website and on which platform did you buy
    I will follow up the question for you
    My email:imalentlight@gmail.com

    https://www.imalentstore.com/


    I don't have the box anymore.
    I conversed with "Candy" at sales@imalent.com
    I provided this person with proof of the sale (from ebay). It was purchased in May 2019, but I have no way to know if the light was made after Nov 2018 or not. Is there a design difference making an incompatibility in the battery before vs after Nov 2018?

    Can you please explain why turning on turbo mode for 3 times would help in this specific situation?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •