Possible issue with Thrunite TC20 V2? Anyone here have one?

MiamiGuitarMan

Newly Enlightened
Joined
Jan 20, 2022
Messages
10
Location
USA
So I just received a new Thrunite TC20 V2. I like everything about it except one thing and I'm not sure if this is normal or if there is a problem with mine. When it's on Medium for more than 5 seconds, if I press/hold the switch to cycle to High, instead of going to High it drops to Low then cycles Low>Med>High.

But if it's on Medium for less than 5 seconds or so it will cycle to High directly from Medium like I'd expect it to. Is this a problem with my light or is this how the UI is supposed to work on these?

I emailed Thrunite and they told me to send it back to Amazon and get it replaced but their email to me was very generic and I'm not sure if they understood what I was talking about. I'd hate to send it back only to get another one that works the same way if this is how they are supposed to work.
 

LRJ88

Enlightened
Joined
May 4, 2014
Messages
385
You’ve already tested with another battery and cleaned the contact surfaces?
 

MiamiGuitarMan

Newly Enlightened
Joined
Jan 20, 2022
Messages
10
Location
USA
You’ve already tested with another battery and cleaned the contact surfaces?
Unfortunately I don't have another battery of this size but I did take the light apart and clean the contacts. I'm hoping to find someone else who has this same light so they can tell me if theirs works the same way mine does.

All the levels work fine. No problem going into Turbo or Firefly. It just isn't cycling directly from Med to High after it has been on for a couple of seconds. It's almost like the UI is configured to jump to Low and start from there no matter what level it is on. Naturally, that means it would only affect going from Med to High because in High, the next mode is Low, and in Low, it's already starting from there.
 

desert.snake

Flashlight Enthusiast
CPF Supporter
Joined
May 8, 2017
Messages
1,701
Location
Eastern Europe
It's strange that at less than 5 seconds it switches to high, judging by the controls, it should immediately switch to low when button hold
1670052230359.png
 

MiamiGuitarMan

Newly Enlightened
Joined
Jan 20, 2022
Messages
10
Location
USA
It's strange that at less than 5 seconds it switches to high, judging by the controls, it should immediately switch to low when button hold
View attachment 35680
When I read that I understand it to mean the mode cycle only works with Low, Med, and High, not the other modes like Turbo, Firefly, or Strobe.

That said, this morning I remembered that I have another Thrunite, a Catapult V6 (I hardly ever use it and temporarily forgot I had it), and tried it and found that its UI works the same way. If left in Med for more than a couple of seconds, holding the button will cause it to drop to Low, then Med, then High, and will not go from Med to High without cycling down to Low first. I guess that answers my question - it's just how Thrunite's UI works.

A bit annoying if I'm ever in a situation where I need to go from Med to High instantly but I guess if that happens I can just double click and jump to Turbo.

The lights I use 99% of the time are Olights and those work as I expect. They have a very similar UI but if I'm in Medium and press/hold the button, it will cycle directly from Med to High without first dropping to Low. I guess I'm so used to that UI that I expected the Thrunite to work the same way.
 
Top