surefire stiletto pro 2

umc

Enlightened
Joined
May 22, 2005
Messages
346
Location
Detroit, MI
Kind of what Monocrom said but the why is because my original stiletto pro 2 was A00992 so pretty close to yours. My new one is A01472 and while still not really far apart number-wise I think this current one may be different.

I received it this Friday and charged it to blinking green (100%) first thing. I played around with it a bit once it got dark and then tried charging it up again before I went into work Friday night but when I plugged it in, it was blinking green already so I figured I must not have used it enough to drop down enough to take a charge. Ok fine.

I tested it out at work Friday night, just played around with the different outputs and seeing how far the throw and spill was, etc. The same thing I did when I got my original, nothing scientific just checking out the light. With my original I took it to work that night fully charged and tested it out, not a ton and not even what I would consider on high for more than a couple minutes total on and off. Maybe a total time of 5 minutes between all modes but what happened then was the next morning I was using it and not long in (seconds) it dropped to orange. I thought that was weird and not expected. That is when I commented on this post and would have to look back at the details of that experience. That is when I tested it on high for 5 minutes constant on and it dropped to orange and then 5-10 more and then to red. That's when I contacted Surefire and sent it in. They said the runtime was the same compared to another they tested against and it sounds on par with your experience. Surefire stated that it's probably more the programing of the battery indicator than run time and I was fine with that.

Well this A01472 is still on green. I used it Friday night, I used it and tested with it Saturday night, and have just played around with it, on high for 10-20-30 seconds (no long minutes at a time) and on medium quite a bit and low a ton and just giving it some general use. Probably how I would normally use it but honestly this is way more than I would need a light at any given time in general. So the same thing yesterday, I used it throughout the day and more at night just seeing how I like the throw and spill. IT'S STILL ON GREEN!!!! This is more of what I expected and am quite shocked that it hasn't dropped to orange yet especially when compared to the first one. I'm getting my hopes up but questioning everything at the same time. lol

So yeah, I'm wondering if maybe there was a problem with a batch of them and it was just random or maybe they discovered that and made a correction along the way, not really sure but there is a clear difference between the two stiletto pro 2's that I have had now and I'm getting pretty damn excited about this new one but only time will tell. I'm oddly afraid to do timed tests at this point for some reason and I think its because I don't want to have it be the same experience as last time but I just want to use it for now and see how it goes.
 

Monocrom

Flashaholic
Joined
Aug 27, 2006
Messages
20,410
Location
NYC
SureFire has a reputation for quietly tweaking their lights, making adjustments, and improvements with later batches. Zero announcements, zero fan-fare. This is across the board with all their models.
 

dddrees

Newly Enlightened
Joined
Mar 7, 2024
Messages
57
Location
Midwest
Kind of what Monocrom said but the why is because my original stiletto pro 2 was A00992 so pretty close to yours. My new one is A01472 and while still not really far apart number-wise I think this current one may be different.

I received it this Friday and charged it to blinking green (100%) first thing. I played around with it a bit once it got dark and then tried charging it up again before I went into work Friday night but when I plugged it in, it was blinking green already so I figured I must not have used it enough to drop down enough to take a charge. Ok fine.

I tested it out at work Friday night, just played around with the different outputs and seeing how far the throw and spill was, etc. The same thing I did when I got my original, nothing scientific just checking out the light. With my original I took it to work that night fully charged and tested it out, not a ton and not even what I would consider on high for more than a couple minutes total on and off. Maybe a total time of 5 minutes between all modes but what happened then was the next morning I was using it and not long in (seconds) it dropped to orange. I thought that was weird and not expected. That is when I commented on this post and would have to look back at the details of that experience. That is when I tested it on high for 5 minutes constant on and it dropped to orange and then 5-10 more and then to red. That's when I contacted Surefire and sent it in. They said the runtime was the same compared to another they tested against and it sounds on par with your experience. Surefire stated that it's probably more the programing of the battery indicator than run time and I was fine with that.

Well this A01472 is still on green. I used it Friday night, I used it and tested with it Saturday night, and have just played around with it, on high for 10-20-30 seconds (no long minutes at a time) and on medium quite a bit and low a ton and just giving it some general use. Probably how I would normally use it but honestly this is way more than I would need a light at any given time in general. So the same thing yesterday, I used it throughout the day and more at night just seeing how I like the throw and spill. IT'S STILL ON GREEN!!!! This is more of what I expected and am quite shocked that it hasn't dropped to orange yet especially when compared to the first one. I'm getting my hopes up but questioning everything at the same time. lol

So yeah, I'm wondering if maybe there was a problem with a batch of them and it was just random or maybe they discovered that and made a correction along the way, not really sure but there is a clear difference between the two stiletto pro 2's that I have had now and I'm getting pretty damn excited about this new one but only time will tell. I'm oddly afraid to do timed tests at this point for some reason and I think its because I don't want to have it be the same experience as last time but I just want to use it for now and see how it goes.
If you don't mind could you test it and see on a full charge how long it will run on high? Try to take note when the light changes.
 
Last edited:

umc

Enlightened
Joined
May 22, 2005
Messages
346
Location
Detroit, MI
Kind of what Monocrom said but the why is because my original stiletto pro 2 was A00992 so pretty close to yours. My new one is A01472 and while still not really far apart number-wise I think this current one may be different.

I received it this Friday and charged it to blinking green (100%) first thing. I played around with it a bit once it got dark and then tried charging it up again before I went into work Friday night but when I plugged it in, it was blinking green already so I figured I must not have used it enough to drop down enough to take a charge. Ok fine.

I tested it out at work Friday night, just played around with the different outputs and seeing how far the throw and spill was, etc. The same thing I did when I got my original, nothing scientific just checking out the light. With my original I took it to work that night fully charged and tested it out, not a ton and not even what I would consider on high for more than a couple minutes total on and off. Maybe a total time of 5 minutes between all modes but what happened then was the next morning I was using it and not long in (seconds) it dropped to orange. I thought that was weird and not expected. That is when I commented on this post and would have to look back at the details of that experience. That is when I tested it on high for 5 minutes constant on and it dropped to orange and then 5-10 more and then to red. That's when I contacted Surefire and sent it in. They said the runtime was the same compared to another they tested against and it sounds on par with your experience. Surefire stated that it's probably more the programing of the battery indicator than run time and I was fine with that.

Well this A01472 is still on green. I used it Friday night, I used it and tested with it Saturday night, and have just played around with it, on high for 10-20-30 seconds (no long minutes at a time) and on medium quite a bit and low a ton and just giving it some general use. Probably how I would normally use it but honestly this is way more than I would need a light at any given time in general. So the same thing yesterday, I used it throughout the day and more at night just seeing how I like the throw and spill. IT'S STILL ON GREEN!!!! This is more of what I expected and am quite shocked that it hasn't dropped to orange yet especially when compared to the first one. I'm getting my hopes up but questioning everything at the same time. lol

So yeah, I'm wondering if maybe there was a problem with a batch of them and it was just random or maybe they discovered that and made a correction along the way, not really sure but there is a clear difference between the two stiletto pro 2's that I have had now and I'm getting pretty damn excited about this new one but only time will tell. I'm oddly afraid to do timed tests at this point for some reason and I think its because I don't want to have it be the same experience as last time but I just want to use it for now and see how it goes.
Just now went to orange. I think I'll keep messing with it like I have been for the week before charging it again and see how long until it hits red. I know nothing scientific but it's definitely different than the first one I had.
 

umc

Enlightened
Joined
May 22, 2005
Messages
346
Location
Detroit, MI
SureFire has a reputation for quietly tweaking their lights, making adjustments, and improvements with later batches. Zero announcements, zero fan-fare. This is across the board with all their models.
That makes sense and hope that's the case here even though it doesn't seem like that big of a range between 992 and 1472 but who knows.
 

umc

Enlightened
Joined
May 22, 2005
Messages
346
Location
Detroit, MI
That makes sense and hope that's the case here even though it doesn't seem like that big of a range between 992 and 1472 but who knows.
and the fact that they were probably all released at the same time. Not like it's been years or even months between when these were produced.
 

umc

Enlightened
Joined
May 22, 2005
Messages
346
Location
Detroit, MI
If you don't mind could you test it and see on a full charge how long it will run on high? Try to take note when the light changes.
Yes. Let me run it for the week without charging just because I'm curious how it does now that it's on orange. Then I'll fully charge it once it hits red and test how long on high from green and full charge to orange.
 

umc

Enlightened
Joined
May 22, 2005
Messages
346
Location
Detroit, MI
So maybe there isn't a difference. Running on a full charge on high for 7 minutes before it hit orange. I'm thinking there is a difference between running nonstop vs. the on and off. I didn't notice it step down but based off of the charts I'm sure it did. Oh well.

My plan is to just carry it and use it and see how it goes and try not to worry about runtimes
 

dano

Flashlight Enthusiast
Joined
Aug 11, 2000
Messages
3,885
Location
East Bay, Cali.
Well. Another defect. On my sample, The top mode button only works about 50% of the time. I can click it and receive no response from the light...Both in on/off and low med hi, or hi med low modes. Will call on Monday, and hopefully SF will accept the RMA. Surefire has become such a disappointment.
 

umc

Enlightened
Joined
May 22, 2005
Messages
346
Location
Detroit, MI
Well. Another defect. On my sample, The top mode button only works about 50% of the time. I can click it and receive no response from the light...Both in on/off and low med hi, or hi med low modes. Will call on Monday, and hopefully SF will accept the RMA. Surefire has become such a disappointment.
I read this the other day and then had a dream last night that mine started doing this. ugh Woke up this morning and when I used it for something I thought about that and then checked it to make sure it was just a dream. lol. weird :)
 

dano

Flashlight Enthusiast
Joined
Aug 11, 2000
Messages
3,885
Location
East Bay, Cali.
Update...I sent it to them, with a note outlining what was wrong with it, and that the light was in lock-out mode (to avoid any accidental activation in the box). They returned the light, stating that it passed run and function tests, and what I was reporting was because I didn't know that the light was in lock-out mode...Even sending me instructions, circled in bright green hi-liter, to unlock the light. I made a video of the malfunction...BUT the light now works fine. Don't know what was done to it.....Odd....
 
Top