Maha C9000 right slot resets the unit

PEU

Flashlight Enthusiast
Joined
Feb 26, 2004
Messages
3,600
Location
Buenos Aires / Argentina (I like ribs)
I purchased a Maha C9000 long time ago, it worked fine, now from time to time if I use all 4 slots at once, the minute I put a battery on the right slot the units resets, begins the autotest sequence and ask me to enter the charge settings for all the slots again.

I recall reading about this problem, but I can't find the thread. Is there a solution? Im handy with electronics. I purchased it at Thomasdistributing

Please keep in mind that shipping the unit back and forth to USA would cost me more than the charger itself :(

Thanks!


Pablo
 

Yoda4561

Flashlight Enthusiast
Joined
Jan 22, 2007
Messages
1,265
Location
Florida, U.S.A.
Since a return is not an option, maybe see if maha has a distributor/warranty center in south america?? Have you tried putting batteries in the right slot first then going left? Does it do the same thing? It could just be the power adapter is going bad, in which case a replacement shouldn't be too hard too find. If you have to take it apart, I'd look for any shorts or swollen caps. If it's not something obvious it's probably the charger's logic chip, which probably means you need to buy a new charger or put up with only 3 slots.
 

PEU

Flashlight Enthusiast
Joined
Feb 26, 2004
Messages
3,600
Location
Buenos Aires / Argentina (I like ribs)
I know no distributors here in Argentina, I tried many combinations, the right slot is problematic. Months after the charger came out I read about this problem but now I can't find the thread here.
Im looking for some hint if this can be solved by me.


Pablo
 

Lynx_Arc

Flashaholic
Joined
Oct 1, 2004
Messages
11,212
Location
Tulsa,OK
I don't have that maha... but are you setting the current on EACH battery as you insert it? If you are setting them to something like the maximum you could try inserting the cells at the minimum one at a time and see if the problem could be a weak component in the power supply unable to supply enough power for all 4 cells.
 

thekobk

Newly Enlightened
Joined
Oct 22, 2006
Messages
104
Location
madison wi
Could be a defective wall wort, try using the car adapter to see if the problem goes away. I happen to have 2 wall wort's so if that is it I will give you one of mine if you pay shipping.
 

Mr Happy

Flashlight Enthusiast
Joined
Nov 21, 2007
Messages
5,390
Location
Southern California
I purchased a Maha C9000 long time ago, it worked fine, now from time to time if I use all 4 slots at once, the minute I put a battery on the right slot the units resets, begins the autotest sequence and ask me to enter the charge settings for all the slots again.

I recall reading about this problem, but I can't find the thread. Is there a solution? Im handy with electronics. I purchased it at Thomasdistributing
There may be something to be deduced from exactly when it resets. Is it the moment the battery touches the contacts, or after you apply pressure to insert the battery down into the slot, or after you complete the slot programming?

If it happens when you push the battery down, it could be something mechanical, like a dry joint or a weak contact. I have not disassembled my own unit, but I have an idea the battery contact springs may be directly fixed to the circuit board. If so, pressing down a battery may flex the board and break a connection.

If it happens when you complete programming, it may be a failed electrical component. The first thing the charger does after you complete programming is apply a large current through the cell to test it. If some component like a capacitor has failed, this large current pulse may produce a power supply disturbance that causes the processor to reset. A problem like this was once reported with LaCrosse BC900 chargers due to inadequate power supply design. In your C9000 a similar symptom could be occurring due to an electrical fault.
 

Lynx_Arc

Flashaholic
Joined
Oct 1, 2004
Messages
11,212
Location
Tulsa,OK
could try putting batteries in from the right first and the left slot would be last......
 

Ziemas

Enlightened
Joined
Dec 28, 2007
Messages
249
Call (or email) Maha and speak to someone there about the problem. The charger comes with a three year warranty. I had a problem with the screen on mine, and Maha replaced it no questions asked without having me send it back.

I purchased a Maha C9000 long time ago, it worked fine, now from time to time if I use all 4 slots at once, the minute I put a battery on the right slot the units resets, begins the autotest sequence and ask me to enter the charge settings for all the slots again.

I recall reading about this problem, but I can't find the thread. Is there a solution? Im handy with electronics. I purchased it at Thomasdistributing

Please keep in mind that shipping the unit back and forth to USA would cost me more than the charger itself :(

Thanks!


Pablo
 

Ziemas

Enlightened
Joined
Dec 28, 2007
Messages
249
Have you tired calling them? I've always gotten very good customer service on the phone from them.
e-mailing Maha doesn't seem to get any results.

I sent them a message months ago that they still have not responded to.
 
Top